This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492919 - rhn proxy logs have changed, and I cant find a log that displays the equivalent of access.log
rhn proxy logs have changed, and I cant find a log that displays the equivale...
Status: CLOSED NOTABUG
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
na
: Reopened
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-03-30 14:13 EDT by wes hayutin
Modified: 2009-08-13 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 09:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-30 14:13:57 EDT
Description of problem:
rhn proxy logs have changed, and I cant find a log that displays the name of the pkgs xferred via the proxy

webui install on 
Satellite-5.3.0-RHEL5-re20090327.0-i386-embedded-oracle.iso
proxy 5.2

root@rlx-3-06 rhn]# pwd
/var/log/rhn
[root@rlx-3-06 rhn]# ls
rhn_proxy_broker.log  rhn_proxy_redirect.log
[root@rlx-3-06 rhn]# 

I'm looking for an equivalent log to squid's access.log
Comment 1 Miroslav Suchý 2009-03-31 03:32:59 EDT
AFAIK it did not changed.
rhn_proxy_broker.log and rhn_proxy_redirect.log are populated only if debug is set to non-zero value in /etc/rhn/rhn.conf

You are probably looking for apache log, which is /var/log/httpd/access_log. For squid it is /var/log/squid/access.log
Comment 2 wes hayutin 2009-03-31 07:46:22 EDT
hrm.. 
I'm wondering why there is a change in the proxy logging?
I'll try and bring up a 5.2 satellite and install a proxy so we can diff the two.
In satellite 4.1 - satellite 5.2 proxy logged by default to the squid access log where you could see the package names that were getting cached.

The new behaviour may be fine, but lets keep this bug open until we can determine what has changed.

Looking at the 5.2 docs for Proxy 5.2 which is what I installed
https://test10-64.rhndev.redhat.com/rhn/help/proxy/rhn520/en/s1-log-files.jsp

Apache Web server  	 /var/log/httpd/ directory
Squid 	/var/log/squid/ directory
RHN Proxy Broker Server 	/var/log/rhn/rhn_proxy_broker.log
RHN SSL Redirect Server 	/var/log/rhn/rhn_proxy_redirect.log
Red Hat Update Agent 	/var/log/up2date

Looks like we should have the logs in /var/log/squid.  
Is there a bug for a documentation change?
Comment 3 wes hayutin 2009-03-31 09:13:41 EDT
this is working on a 5.3 proxy that msuchy installed.

My proxy was a 5.2 proxy on sat 5.3 
I'll recheck on both 5.3 and 5.2 proxy

Note You need to log in before you can comment on or make changes to this bug.