This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 492926 - gnome-vfs2 i586 and x86_64 conflicts
gnome-vfs2 i586 and x86_64 conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-30 15:33 EDT by Robert de Rooy
Modified: 2015-03-03 17:40 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-vfs2-2.24.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 04:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert de Rooy 2009-03-30 15:33:36 EDT
Description of problem:
I have both the x86_64 and i586 version of gnome-vfs2 installed, due to some 3rd party dependency.

The old versions are gnome-vfs2-2.24.0-5.fc11.x86_64 and gnome-vfs2-2.24.0-5.fc11.i586

New versions have been released, but when I try to install them with yum I get conflicts between them

Version-Release number of selected component (if applicable):
Old installed versions;
gnome-vfs2-2.24.0-5.fc11.x86_64
gnome-vfs2-2.24.0-5.fc11.i586

New versions in repository;
gnome-vfs2-2.24.1-1.fc11.x86_64
gnome-vfs2-2.24.1-1.fc11.i586

How reproducible:
upgrade gnome-vfs2 when both the x86_64 and i586 packages are installed

Steps to Reproduce:
1.Install fedora11 alpha x86_64
2.Install gnome-vfs2.i586
3.Upgrade gnome-vfs2 to latest release
  
Actual results:
Transaction Check Error:
  file /usr/share/locale/af/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/am/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ar/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/as/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ast/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/az/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/be/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/bg/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/bn/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/bn_IN/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/bs/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ca/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/cs/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/cy/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/da/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/de/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/dz/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/el/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/en_CA/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/en_GB/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/eo/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/es/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/et/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/eu/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/fa/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/fi/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/fr/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ga/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/gl/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/gu/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/he/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/hi/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/hr/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/hu/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/id/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/is/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/it/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ja/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ka/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/kn/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ko/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ku/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/li/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/lt/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/lv/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/mai/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/mg/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/mk/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ml/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/mn/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/mr/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ms/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/nb/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ne/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/nl/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/nn/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/nso/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/oc/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/or/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/pa/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/pl/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/pt/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/pt_BR/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ro/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ru/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/rw/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sk/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sl/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sq/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sr/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sr@ije/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sr@latin/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/sv/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/ta/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/te/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/th/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/tr/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/uk/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/uz/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/uz@cyrillic/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/vi/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/wa/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/xh/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/yi/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/zh_CN/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/zh_HK/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/zh_TW/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586
  file /usr/share/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo conflicts between attempted installs of gnome-vfs2-2.24.1-1.fc11.x86_64 and gnome-vfs2-2.24.1-1.fc11.i586

Error Summary
-------------

Expected results:
Upgrade to succeed

Additional info:
Comment 1 Tomáš Bžatek 2009-04-02 08:07:08 EDT
Can you please try gnome-vfs2-2.24.1-2.fc11?
http://koji.fedoraproject.org/koji/buildinfo?buildID=96339
Comment 2 Robert de Rooy 2009-04-02 16:12:40 EDT
It worked, on a fresh F11 beta install, i downloaded the x86_64 and i586 packages from koji and did:
yum install --nogpgcheck gnome-vfs2-2.24.1-2.fc11.*

It pulled in all the i586 dependencies and installed without error.

Thanks for the rapid response!
Comment 3 Tomáš Bžatek 2009-04-03 04:59:35 EDT
Great! Closing.

These builds are from the official build system, no need to specify --nogpgcheck
Comment 4 Robert de Rooy 2009-04-03 05:37:24 EDT
Actually I did need to specify --nogpgcheck as I got an error before that the packages where not signed.

Note You need to log in before you can comment on or make changes to this bug.