This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 492929 - ibus-hangul can cause gtk app to lockup
ibus-hangul can cause gtk app to lockup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker 481098
  Show dependency treegraph
 
Reported: 2009-03-30 15:47 EDT by Warren Togami
Modified: 2009-04-07 00:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 00:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-03-30 15:47:48 EDT
gtk2-2.16.0-1.fc11.x86_64
gedit-2.26.0-1.fc11.x86_64
ibus-1.1.0.20090311-3.fc11.x86_64
ibus-hangul-1.1.0.20090328-1.fc11.x86_64

1) Run gedit.
2) Activate ibus-hangul.
3) Type "wkk"
4) Use hotkeys to cycle through all engines, then back to Hangul.
5) Hit Backspace a few times.
6) gedit locks up.
Comment 1 Peng Huang 2009-03-31 00:52:02 EDT
Please update ibus to 1.1.0.2009331-1, and try again. Thanks
Comment 2 Warren Togami 2009-04-02 01:03:41 EDT
Still broken.
Comment 3 Warren Togami 2009-04-02 17:35:39 EDT
There seem to be numerous other ways in which ibus-hangul can cause the entire GTK+ app to lockup.  It happened to me a few times by only Alt-Shift cycling through my active engines.  Bumping up priority because this is pretty bad.
Comment 4 Jens Petersen 2009-04-03 23:57:22 EDT
I can't reproduce exactly - for me when I cycle back to Hangul it just stops working - ie I can only continue to input ascii even though ibus says hangul is activated but the config button is gone from the toolbar.  (Additionally I can get next-engine bindings with Alt to work though this is under virt if it matters.)
Comment 5 Warren Togami 2009-04-06 16:04:02 EDT
It seems the most common way to cause the gtk+ app to lockup is if you next-engine cycle from hangul.  I can however get the gtk+ app to lockup sometimes when attempting hanja character conversion.  Like: wk then press F9.
Comment 6 Warren Togami 2009-04-06 17:10:23 EDT
ibus-hangul, no next-engine switching, just hitting the Hanja button often locks up here.

#0  0x000000358f2d63b8 in *__GI___poll (fds=0x7fff6b5aa9f0, nfds=1, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:83
#1  0x0000003595e23d40 in socket_do_iteration (transport=0x23b5d50, flags=6, timeout_milliseconds=-1) at dbus-transport-socket.c:1046
#2  0x0000003595e2213d in _dbus_transport_do_iteration (transport=0x23b5d50, flags=<value optimized out>, timeout_milliseconds=<value optimized out>) at dbus-transport.c:956
#3  0x0000003595e0e7ce in _dbus_connection_do_iteration_unlocked (connection=0x23850f0, flags=6, timeout_milliseconds=-1) at dbus-connection.c:1150
#4  0x0000003595e10900 in _dbus_connection_read_write_dispatch (connection=0x23850f0, timeout_milliseconds=-1, dispatch=<value optimized out>) at dbus-connection.c:3446
#5  0x00007fc65a4c6e3d in ibus_input_context_process_key_event (context=<value optimized out>, keyval=65508, state=0) at ibusinputcontext.c:576
#6  0x00007fc65a6eab4b in ibus_im_context_filter_keypress (context=0x21dcd00, event=0x22c6910) at ibusimcontext.c:361
#7  0x00000034ebb2955d in gtk_invoke_key_snoopers (event=<value optimized out>, grab_widget=<value optimized out>) at gtkmain.c:1908
#8  IA__gtk_main_do_event (event=<value optimized out>, grab_widget=<value optimized out>) at gtkmain.c:1593
#9  0x00000034eb64e7cc in gdk_event_dispatch (source=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at gdkevents-x11.c:2364
#10 0x00007fc662a2706e in g_main_dispatch (context=<value optimized out>) at gmain.c:1814
#11 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
#12 0x00007fc662a2a7c8 in g_main_context_iterate (context=0x20827b0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2448
#13 0x00007fc662a2ac65 in IA__g_main_loop_run (loop=0x237d000) at gmain.c:2656
#14 0x00000034ebb297e7 in IA__gtk_main () at gtkmain.c:1205
#15 0x000000000042830c in main ()

NOTE: If we cannot fix this before Fedora 11, we need to backout to the pre-Hanja ibus-hangul.  It sucks, but the desktop is at least usable.
Comment 7 Peng Huang 2009-04-07 00:43:00 EDT
I think it is a bug in ibus. I fixed in ibus-1_1_0_20090407-1_fc11. Please test it.

Note You need to log in before you can comment on or make changes to this bug.