Bug 49293 - oops 0000; ?swapfile corruption?
Summary: oops 0000; ?swapfile corruption?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-17 18:39 UTC by pdenis2
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 21:17:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ksymoops /var/log/messages (2.74 KB, text/plain)
2001-07-17 18:41 UTC, pdenis2
no flags Details
oops output (7.85 KB, text/plain)
2001-07-19 21:16 UTC, pdenis2
no flags Details

Description pdenis2 2001-07-17 18:39:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
netscape and emacs suddenly failed with "unresolved sym XtBindAction" in
libXt.so.6.  rpm -V XFree86-libs shows ...5 ... error in libXt.so.6. 
Simulataneous kernel oops 0000 in logs.  Reboot and everything OK
***including rpm -V XFree86-libs***.

How reproducible:
Didn't try


Additional info:

Linux pogo.private.network 2.4.3-12 #1 Fri Jun 8 15:05:56 EDT 2001 i686
unknown
vid=NVIDIA; mb=k7v-133; athlon 1.2GHz 256 MB RAM/512 swap.
Oops file to be attached.
Reboot msgs showed trouble unmounting /tmp (busy).
Something got (mis)-cached involving libXt.so.6 and didn't get reset until
reboot...Hardware? Cosmic ray?

Comment 1 pdenis2 2001-07-17 18:41:50 UTC
Created attachment 23916 [details]
ksymoops /var/log/messages

Comment 2 Arjan van de Ven 2001-07-18 10:06:01 UTC
Are you using the NVidia provided propriatry kernel module ?


Comment 3 pdenis2 2001-07-18 17:54:52 UTC
Yes.  NVIDIA drivers , NVIDIA_kernel and _GLX are Version 1.0-1251 from rpms . 
Have had occasional X and kbd. lockups (have to reboot via alt-sysrq-s/u/b) but
no oopses or kernel crashes.
Correction to orig: MB=**A**7V133; Promise HD controller NOT connected (just 
using ata66)

Comment 4 Arjan van de Ven 2001-07-18 17:58:02 UTC
I've seen several similar reports where the nvidia module has effects that
really really point to corrupted memory. There's nothing we can do about that,
unfortionatly.

Comment 5 pdenis2 2001-07-18 18:23:12 UTC
OK, thanks, I'll go back to using XFree drivers.  Maybe RH could politely
express their displeasure to NVidia -- they have a rep. for not listening to
consumers.


Comment 6 Arjan van de Ven 2001-07-18 18:30:51 UTC
Trust me.. we tried ...

Comment 7 pdenis2 2001-07-19 21:16:24 UTC
Created attachment 24227 [details]
oops output

Comment 8 pdenis2 2001-07-19 21:17:09 UTC
Still have stability problems *after* getting rid of NVIDIA drivers (I renamed
the files and repointed the links to the XFree+Mesa stuff:  lsmod (under X) no
longer shows nv_driver, /usr/bin/gears runs unaccelerated (132fps), and xfree
log shows only (NV).
But: 1) system was locked up this AM; sysrq s/u/b. nothing in logs.
2) ran OK, then over lunch found a new oops. (attached)
3) what's going on?  this really looks like kernel instability and there seem to
be a lot of recent postings like this via dejanews search, all involving
a7v-type MBs.  My system is neither overclocked nor overheated (CPU=52 C).

I think I'll try torture testing like kernel building...


Comment 9 pdenis2 2001-07-20 17:24:28 UTC
I give up -- it's got to be hardware problems.  Got a segfault in X and rpm -V filename itself segfaulted.  After reboot rpm -V was OK.
After next crash reboot showed fs corruption on every partition (bad/dup blocks ...).  Maybe memory errors in the disk buffers. 

The box is going back and the next one 
won't contain any of the words athlon, VIA, NVIDIA or PogoLinux.
Sorry to have wasted your time (again).


Note You need to log in before you can comment on or make changes to this bug.