Bug 492949 - Trees from new satellite-sync are not synced to Cobbler
Trees from new satellite-sync are not synced to Cobbler
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-03-30 17:03 EDT by Steve Salevan
Modified: 2009-09-10 15:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-03-30 17:03:20 EDT
Description of problem:
This one might or might not be a bug, but mmccune and I thought that it'd be a good idea to write up a bug on this issue to expand the discussion past ourselves.

Let's say that a user has some distro configurations in /var/lib/cobbler/config/distros.d/ that share the name of a kickstart tree that someone might sync from hosted (such as ks-rhel-i386-server-5-u3).

If a user has not synced these actual kickstart trees before from hosted and performs a satellite-sync, the Satellite will not report them as being synced upon its completion.  Furthermore, if a user attempts to access the profile creation page located here:

/rhn/kickstart/CreateProfileWizard.do

variations on the theme of the following message will appear in /var/lib/tomcat5/catalina.out:

2009-03-30 17:01:30,666 [TP-Processor7] ERROR com.redhat.rhn.manager.kickstart.KickstartWizardHelper - This Kickstart tree does not have an associated cobbler distro: ks-rhel-i386-server-5-u3

Version-Release number of selected component (if applicable):
530-re20090327.0

How reproducible:
Always

Steps to Reproduce:
1. Add some config files to /var/lib/cobbler/config/distros.d/ that share the name of a kickstart tree from RHN Hosted
2. Sync the constituent kickstart tree from RHN Hosted
3. Visit /rhn/kickstart/CreateProfileWizard.do
  
Actual results:
Kickstart tree does not appear in available kickstart tree list

Expected results:
Kickstart tree appears in available kickstart tree list

Additional info:
Comment 1 Steve Salevan 2009-03-31 10:46:10 EDT
From talking to Preethi, it appears that, even on a freshly provisioned machine that has never had a Cobbler installation (and thereby no old distro configurations), trees from satellite-sync are not synced to Cobbler.

Mike McCune adds:

<mmccune-mtg> caused by busted taskomatic
<mmccune-mtg> from:
<mmccune-mtg> /var/log/rhn/rhn_taskomatic_daemon.log
<mmccune-mtg>  Caused by: 
<mmccune-mtg> INFO   | jvm 1    | 2009/03/30 11:09:01 | redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'login failed: taskomatic_user'

So, it looks like we're going to bump up the priorities, change the title of this bug to:

Trees from new satellite-sync are not synced to Cobbler

and move it over to the sat530-qa-blockers bug.
Comment 2 Justin Sherrill 2009-04-02 15:50:40 EDT
restarting taskomatic seems to solve the issue.  Going to see what the issue is to not require a restart.
Comment 3 Justin Sherrill 2009-04-03 10:50:16 EDT
removing this bug from qa blockers and putting   https://bugzilla.redhat.com/show_bug.cgi?id=490866 in its place.   


This bz is about the Description, not comment #1.  I'm addressing comment #1 in bz 490866.
Comment 4 Justin Sherrill 2009-04-06 15:50:00 EDT
commits: 

ff70d7382b5052aa7973eed1dcb358d668b5599a
bd0277099fe26cc367b2a86b97d597d819c59c56


now during the DistroSync process, we check to see if cobbler already has a Distro with the name we would name it.  If it exists, we simply reuse it.
Comment 5 Steve Salevan 2009-05-15 13:09:52 EDT
VERIFIED on 5/7 ISO.
Comment 6 Preethi Thomas 2009-07-30 07:57:06 EDT
release pending 
7/24 stage ISO 
https://sun-x4200-01.rhts.bos.redhat.com/
followed steve's test plan and was able to satellite sync without errors.
Comment 7 Brandon Perkins 2009-09-10 15:24:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.