Bug 492958 - xen driver serial mode 'unix' sexpr is not built correctly
xen driver serial mode 'unix' sexpr is not built correctly
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 18:00 EDT by Cory Bennett
Modified: 2011-03-17 10:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:24:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for qemu-dm via xend to allow for unix-domain-socket serial files (2.16 KB, patch)
2009-03-30 18:00 EDT, Cory Bennett
no flags Details | Diff

  None (edit)
Description Cory Bennett 2009-03-30 18:00:44 EDT
Created attachment 337249 [details]
patch for qemu-dm via xend to allow for unix-domain-socket serial files

Description of problem:
Per XML spec:
http://libvirt.org/formatdomain.html#elementsCharUNIX
This should be allowed:
<serial type="unix">
  <source mode="bind" path="/path/to/serial"/>
  <target port="1"/>
</serial>

The xend log reports for the "qemu-dm" command it is using:
[..., '-serial', 'unix:/path/to/serial,listen', ...]

the "listen" part is not valid, it should be ",server,nowait"
like is currently specified in qemu_conf.c

A similar patch to the one applied to qemu_conf.c need to be applied to xend_internal.c also.

I will attach the patch (diff from git trunk).

Version-Release number of selected component (if applicable):

git trunk (all versions?)


How reproducible:

Steps to Reproduce:
1. Create any XEN DomU via Libvirt with Unix Domain Socket for serial
  
Actual results:

DomU fails to start, with DM error logged to /var/log/xen/qemu-dm.<name>.log


Expected results:

DomU starts and creates Unix Domain Socket at specified path.


Additional info:
Comment 1 Cole Robinson 2010-05-25 22:31:16 EDT
This code has completely changed upstream, but still seems to have the error in xenDaemonFormatSxprChr.
Comment 2 Cole Robinson 2011-03-17 10:24:51 EDT
Upstream since last year:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=953809dbe4fd18cc69b3fd814782bed77342e7e1

Note You need to log in before you can comment on or make changes to this bug.