Bug 492959 - Dell Wireless 365 bluetooth not working properly
Dell Wireless 365 bluetooth not working properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 18:00 EDT by Matthias Saou
Modified: 2009-09-14 12:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 12:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from lsusb -v (71.26 KB, text/plain)
2009-03-30 18:00 EDT, Matthias Saou
no flags Details
dmesg after resume (63.87 KB, text/plain)
2009-04-23 09:37 EDT, Pietro Bertera
no flags Details
lspci -v (11.30 KB, text/plain)
2009-04-23 09:37 EDT, Pietro Bertera
no flags Details

  None (edit)
Description Matthias Saou 2009-03-30 18:00:45 EDT
Created attachment 337250 [details]
Output from lsusb -v

I've installed Fedora 10 x86_64 on a Dell E4200 laptop. I'm still struggling to get the bluetooth to work properly.

It's an internal Dell Wireless bluetooth module. After a normal boot, I get a total of 107 similar lines as follows in the dmesg output (only the pid changes) :
usb 3-1.2: usbfs: process 1955 (hid2hci) did not claim interface 0 before use

This is with kernel 2.6.27.21-170.2.56.fc10.x86_64.

In order to get the bluetooth to actually be able to see anything, I've had to run "hciconfig hci0 reset". It seems like having set "options btusb reset=1" has this done automatically now, so I no longer need to reset manually. And from what I've read, this might already be known, just not in the kernel I'm running :
http://marc.info/?l=linux-bluetooth&m=122581595524432&w=2

But I still have an issue which I'm unable to debug. I manage to pair with my Nokia E51 phone, but the computer appears on the phone with a generic bluetooth icon instead of a computer icon (which I have for all other computers I paired the phone with). From there, nothing works : Sending files, browsing files, not even wvdial to open a ppp connection. Each time I try to perform a bluetooth related action on the computer, I see the icon for an active bluetooth connection show up on the phone, but nothing more happens (and I have no idea how, if possible, to get useful information from the phone...).

My impression is that the computer is being recognized as a wrong peripheral for some reason. I've double checked the main.conf bluetooth file I'm using and it should be fine (I tried the default, then also forcing some values with the samee result).

To rule out any possible higher level software issue, I tried plugging in an old USB bluetooth dongle I still have... it worked just fine, and right away. So it's definitely a problem specific to the Dell Wireless 365.

I've attached the full lsusb -v output. Any help or suggestions are welcome.
Comment 1 Matthias Saou 2009-04-01 05:54:37 EDT
Some new information :

I tried a Fedora 11 x86_64 Beta Live CD, and using it, bluetooth wasn't working at all until I ran "hid2hci", but after that and pairing the device to my phone, the phone had the computer with the correct icon and I was able to send a file to the phone!

So I did a "yum update" to Rawhide (yes, I'm reckless ;-)), but with the installed system, I get the same problem as before, though the icon on the phone is a computer. The error is "connection reset by peer". I'll continue digging.
Comment 2 Matthias Saou 2009-04-01 08:33:58 EDT
More testing results, detailed :
 * hcitool {dev,inq,scan} work fine
 * I can properly scan and pair with the GNOME bluetooth applet
 * When I try to send a file via the bluetooth applet, the phone doesn't seem to get any incoming connection (its icon doesn't change), and I get "Service search failed (Host is down)". I also tried with 2 other phones, same thing

I tried manually establishing a connection, in case the problem is with something the applet does, but no luck :

[root@fusion ~]# hcitool scan
Scanning ...
	00:1F:E1:DC:70:D8	nagpur
	00:21:08:D1:89:0D	Thias's E51
	00:21:08:D1:EC:DC	Cazzuto6
	00:02:EE:D3:80:A8	Thias's Nokia
[root@fusion ~]# hcitool cc 00:21:08:D1:89:0D
Can't create connection: Input/output error
[root@fusion ~]# hcitool info 00:21:08:D1:89:0D
Requesting information ...
Can't create connection: Input/output error
[root@fusion ~]# hcitool inq
Inquiring ...
	00:1F:E1:DC:70:D8	clock offset: 0x0226	class: 0x182000
	00:02:EE:D3:80:A8	clock offset: 0x5514	class: 0x520204
	00:21:08:D1:89:0D	clock offset: 0x31e8	class: 0x5a020c
	00:21:08:D1:EC:DC	clock offset: 0x39d7	class: 0x5a020c
[root@fusion ~]# hciconfig hci0
hci0:	Type: USB
	BD Address: 00:23:4E:D2:84:11 ACL MTU: 1021:8 SCO MTU: 64:1
	UP RUNNING PSCAN ISCAN 
	RX bytes:7120 acl:0 sco:0 events:254 errors:0
	TX bytes:4389 acl:0 sco:0 commands:167 errors:0

I've checked dmesg and /var/log/messages but found nothing useful. I double checked selinux, but that's not it either. What else could I try to help debug the problem further?
Comment 3 Matthias Saou 2009-04-03 17:15:13 EDT
More (hopefully) useful information :

Now running 2.6.29.1-37.rc1.fc11.x86_64, I tried again after 22h of uptime (Rawhide seems much more stable than Fedora 10 with the Intel video chipset in the Latitude 4200! Yay!) and... it all worked! I sent a file to my phone, I browsed the files on my phone and even my 3G connection using wvdial worked fine (after "rfcomm bind all").

I then rebooted to check if everything would still work, but nope. Back to the previous problems.

Then I suspended the laptop, resumed, and tried again. All works!

So there it is : Whatever is done at suspend/resume time is enough to get the Dell Wireless 365 bluetooth adapter working.

Let me know if attaching any log files or dmesg would be useful.
Comment 4 Pietro Bertera 2009-04-23 09:35:29 EDT
I have the same problem:
bluetooth works only after a suspend/resume:

my kernel is 2.6.29.1-30.fc10.x86_64
my laptop is DELL latitude e4300

[pietro@bertuccia pietro]# hcitool scan
Scanning ...
	00:22:FD:0C:1A:32	Bert
[root@bertuccia pietro]# hcitool cc 00:22:FD:0C:1A:32
Can't create connection: Input/output error
[root@bertuccia pietro]# hcitool info 00:22:FD:0C:1A:32
Requesting information ...
Can't create connection: Input/output error
[root@bertuccia pietro]# hcitool inq
Inquiring ...
	00:1B:63:57:B5:42	clock offset: 0x69e5	class: 0x102104
	00:1C:9A:73:C1:2E	clock offset: 0x254a	class: 0x5a020c
	00:16:41:64:A5:9A	clock offset: 0x627e	class: 0x00010c
	00:1D:6E:C4:90:5B	clock offset: 0x0a61	class: 0x5a020c
	00:21:4F:B4:6E:68	clock offset: 0x0bfb	class: 0x18010c
	00:22:FD:0C:1A:32	clock offset: 0x444e	class: 0x5a020c
[root@bertuccia pietro]# hcitool info 00:22:FD:0C:1A:32
Device is not available or not connected.

===================================================
at this point i have suspend and resume my notebook
===================================================

[root@bertuccia pietro]# hid2hci 
Switching device 413c:8162 to HCI mode was successful
[root@bertuccia pietro]# hcitool info 00:22:FD:0C:1A:32
Requesting information ...
	BD Address:  00:22:FD:0C:1A:32
	OUI Company: Nokia Danmark A/S (00-22-FD)
	Device Name: Bert
	LMP Version: 2.0 (0x3) LMP Subversion: 0x6cc
	Manufacturer: Cambridge Silicon Radio (10)
	Features: 0xbf 0xee 0x0f 0x46 0x98 0x19 0x00 0x00
		<3-slot packets> <5-slot packets> <encryption> <slot offset> 
		<timing accuracy> <role switch> <sniff mode> <RSSI> 
		<channel quality> <SCO link> <HV3 packets> <u-law log> 
		<A-law log> <CVSD> <paging scheme> <power control> 
		<transparent SCO> <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> 
		<inquiry with RSSI> <AFH cap. slave> <AFH class. slave> 
		<3-slot EDR ACL> <5-slot EDR ACL> <AFH cap. master> 
		<AFH class. master>
Comment 5 Pietro Bertera 2009-04-23 09:37:00 EDT
Created attachment 340936 [details]
dmesg after resume

I attach my dmesg after resume
Comment 6 Pietro Bertera 2009-04-23 09:37:55 EDT
Created attachment 340937 [details]
lspci -v

I attach my lspci -v
Comment 7 Matthias Saou 2009-09-14 12:26:32 EDT
FWIW, bluetooth has been working fine for a while now with Fedora 11 on the Latitude E4200 laptop mentioned in the initial report.

The only issue left is that although everything is there to take care of running the correct hid2hci command on boot, I still need to run it manually after each resume from S3, otherwise the bluetooth adapter isn't seen.

So basically the issue is now the opposite : Bluetooth only works before a suspend/resume, but I'll close this report since it's not kernel related anymore for sure.

Note You need to log in before you can comment on or make changes to this bug.