Bug 492962 - gnome-sudoku - fails to start: Assertion error
gnome-sudoku - fails to start: Assertion error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 18:19 EDT by Tom London
Modified: 2009-04-01 22:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 22:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"tar cf sudoku.tar .sudoku" (160.00 KB, application/octet-stream)
2009-03-31 09:21 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2009-03-30 18:19:37 EDT
Description of problem:
Attempting to run 'gnome-sudoku', I get:

[tbl@tlondon streamripper-1.64.5]$ gnome-sudoku 
Traceback (most recent call last):
  File "/usr/bin/gnome-sudoku", line 67, in <module>
    start_game()
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/gnome_sudoku.py", line 22, in start_game
    main.start_game()
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/main.py", line 970, in start_game
    u = UI()
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/main.py", line 172, in __init__
    if self.select_game():
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/main.py", line 65, in _
    ret = fun(ui,*args,**kwargs)
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/main.py", line 185, in select_game
    choice = game_selector.NewOrSavedGameSelector().run_swallowed_dialog(self.swallower)
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/game_selector.py", line 184, in run_swallowed_dialog
    self.setup_dialog()
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/game_selector.py", line 76, in setup_dialog
    self.make_saved_game_model()
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/game_selector.py", line 147, in make_saved_game_model
    sudoku.sudoku_grid_from_string(g['game'].split('\n')[1].replace(' ','')).grid,
  File "/usr/lib/python2.6/site-packages/gnome_sudoku/sudoku.py", line 229, in sudoku_grid_from_string
    assert(len(s)<=GROUP_SIZE**2)
AssertionError
[tbl@tlondon streamripper-1.64.5]$ 

Reverting to previous version (gnome-games-2.25.92-1.fc11.x86_64) does NOT fix.


Version-Release number of selected component (if applicable):
gnome-games-2.26.0-1.fc11.x86_64
gnome-games-2.25.92-1.fc11.x86_64

How reproducible:
Every time....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2009-03-31 01:19:10 EDT
Seems to be a crash in code handling saved games. 
Can you attach the contents of ~/.sudoku/saved and ~/.sudoku/finished ?
Comment 2 Tom London 2009-03-31 09:21:51 EDT
Created attachment 337299 [details]
"tar cf sudoku.tar .sudoku"

Per request, I tar'ed up .sudoku and attached.
Comment 3 Matthias Clasen 2009-04-01 14:24:06 EDT
With that data, my gnome-sudoku crashes as well.
Comment 4 Tom London 2009-04-01 14:38:19 EDT
Worthwhile me trying to 'bisect' the files?
Comment 5 Tom London 2009-04-01 14:43:54 EDT
OK, that was easy.

If I delete the single file in .sudoku/saved I can start the game.
Comment 6 Matthias Clasen 2009-04-01 14:51:50 EDT
I was just going for upstreaming this bug...
Comment 7 Matthias Clasen 2009-04-01 15:02:08 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=577635
Comment 8 Matthias Clasen 2009-04-01 22:09:45 EDT
Built a workaround in gnome-games-2.26.0-2.fc11

Note You need to log in before you can comment on or make changes to this bug.