Bug 49299 - grub cannot see second disk
Summary: grub cannot see second disk
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-17 18:55 UTC by Gene Czarcinski
Modified: 2015-01-07 23:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 20:56:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2001-07-17 18:55:06 UTC
Description of Problem:
With grub install in a small system on hda1 with grub installed into the
mbr of hda. I then installed a default custom install on hdb5 with lilo
installed into hdb5.  I then rebooted the system and selected command-line
mode with the intent to enter the following commands:

root (hd1,4)
chainloader +1
boot

How Reproducible:
everytime on one system ... will try other hardware tonight

Steps to Reproduce: (see above)
1.
2.
3.

Actual Results:
after entering "root (hd1,4)" the respons is

Error 21:   Selected disk does not exist.

Expected Results:

system on hdb5 boots
Additional Information:
	
I tried other partitions on hdb with the same result.  Do installs into
additional partitions on hda (lilo or grub) work as I would expect.

Comment 1 Glen Foster 2001-07-18 19:59:56 UTC
This defect should be fixed before next release.

Comment 2 Gene Czarcinski 2001-08-06 19:31:56 UTC
This only occurs for me on one (Dell Optiplex) system.  Is there any info that
might help?

Comment 3 Jeremy Katz 2001-08-06 20:54:01 UTC
What does the /boot/grub/device.map look like?

Comment 4 Gene Czarcinski 2001-08-07 16:12:26 UTC
1. The /boot/grub/device.map on hda1 which I am trying to use as may master boot
"director" has:

(fd0)    /dev/fd0
(hd0)    /dev/hda

I tried adding the line: (hd1)   /dev/hdb
but this had no effect.

2.  I cannot use grub to chainloader boot from /dev/hdb1 (does not see the disk)
nor can I use "grub on a floppy" to see /dev/hdb1.  However, Once I boot up the
minimal system on /dev/hda1, I can run grub and it will recognize (see) the ext2
file system on (hd1,0).

3.  I have other systems with two ide drives and can use such a "master
director" to boot linux partitions from with the hda or the hdb disks.

Comment 5 Jeremy Katz 2001-08-07 21:04:23 UTC
Have you tried re-running `/sbin/grub-install /dev/hda` after adding the

(hd1)  /dev/hdb

to /boot/grub/device.map?

Comment 6 Gene Czarcinski 2001-08-14 13:37:28 UTC
Sorry that followup took so long but I forgot about this one.

I tried changing device.map and doing grub-install /dev/hda and it makes no
difference.  For some reason, grub on /dev/hda (or a floppy) do not like
/dev/hdb.  Whereas, running grub under a copy of roswell installed on hda can
access /dev/hdb just fine.



Comment 7 Jeremy Katz 2001-08-15 18:45:04 UTC
Well, in an installed system, the accessing of devices doesn't actually use the
BIOS routines, so it's a bit different.  Maybe try updating the BIOS?

Comment 8 Gene Czarcinski 2001-08-24 18:41:41 UTC
This still happens on RC1 and I have no idea how to get around it.

This does NOT happen on any other system I have run tests on.

Comment 9 Jeremy Katz 2001-08-24 18:47:12 UTC
Do you have the newest BIOS available installed on the machine?

Comment 10 Gene Czarcinski 2001-08-24 20:04:46 UTC
This box is a commercial Dell Optiplex purchased about too years ago plus an
extra (IBM) 45MB ide drive.

You have a good question but it will take me a few days (a week?) to check this
out.  I will also try another more or less identical box to see if it acts the same.

Comment 11 Jeremy Katz 2001-09-04 20:56:27 UTC
Any information on updated BIOS ?

Comment 12 Jeremy Katz 2001-11-29 01:38:46 UTC
Closing due to the lack of activity.


Note You need to log in before you can comment on or make changes to this bug.