This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 492994 - rc.sysinit does not clean /var/run/dovecot/master.pid at startup causing it to fail
rc.sysinit does not clean /var/run/dovecot/master.pid at startup causing it t...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 02:19 EDT by Milan Kerslager
Modified: 2011-10-05 15:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: initscripts-8.45.32-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:05:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2009-03-31 02:19:22 EDT
rc.sysinit is cleaning up /var/run every startup, but the file /var/run/dovecot/master.pid is not removed. Dovecot then does not start.

Please fix rc.sysinit to not only delete /var/run/dovecot/*/* but /var/run/dovecot/master.pid too. This directory should be cleaned up even dovecot's check for staled PID file is broken.
Comment 1 Bill Nottingham 2009-03-31 11:15:09 EDT
I find it hard to believe this has been broken this way since 2004, and no one has filed a bug before now. Is that really the case?
Comment 2 Milan Kerslager 2009-09-14 01:49:01 EDT
I had to manually clean up /var/run/dovecot/* after unexpected server crash. I wonder why /var/run/dovecot/*/* files are deleted by rc.sysinit but /var/run/dovecot/* are not.
Comment 3 RHEL Product and Program Management 2010-06-04 16:39:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2011-01-13 18:05:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0075.html
Comment 8 Charlie Brady 2011-10-05 15:23:51 EDT
This "fix" introduced a regression. Now rc.sysinit shows an error message:

rm: Cannot remove '/var/run/dovecot/login': is a directory
Comment 9 Charlie Brady 2011-10-05 15:25:16 EDT
Note that /var/run/dovecot/login is owned by the dovecot rpm, so shouldn't be removed.

Note You need to log in before you can comment on or make changes to this bug.