This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493002 - Nedit Copy and Paste Failure
Nedit Copy and Paste Failure
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nedit (Show other bugs)
5.5
All Linux
low Severity high
: rc
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 04:26 EDT by Richard Baxter
Modified: 2013-07-02 19:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 09:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Baxter 2009-03-31 04:26:56 EDT
Description of problem:

Bug Part A;
(Part A) Nedit fails to copy and paste to and from external applications (Eg firefox/Adobe Reader) {and itself} via Ctrl-C and Ctrl-V. When Nedit is opened initially copy and paste work, however copy and paste start to fail after  opening another application which uses a Ctrl-C/Ctrl-V clipboard (Eg Firefox/Adobe Reader) {sometimes in combination with opening more than one nedit window}. Once this bug has started to occur, another bug (Part B) will occur under certain circumstances; Nedit will crash when copy and pasting into Find/Replace dialog box.

Version-Release number of selected component (if applicable):

This is a very Fedora bug which has never been fixed, although some degree of effort has gone into fixing various symptoms of this bug.

This bug is within all recent versions of Nedit released by Fedora Project; definitely FC6 and FC10. (I assume the same problem occurred on FC7, FC8 and FC9 also). Note FC3 definitely worked. (I assume FC1, FC2, FC4 and FC5 worked as well). Note the Nedit linux executable from nedit.org/sourceforge works fine - it does not have this bug.

How reproducible:

very easy to reproduce.

Steps to Reproduce:

Bug Part A;
1. Open Nedit {open more than one nedit window}
2. Open Firefox
3. Open Adobe Reader 8
4. Copy and paste some text around via Ctrl-C and Ctrl-V, between applications;
5. Copy and paste via Ctrl-C and Ctrl-V from Nedit to Adobe Reader.
6. Copy and paste via Ctrl-C and Ctrl-V from Adobe Reader to nedit - notice failure
7. {Try copying and pasting some text from nedit to nedit via Ctrl-C and Ctrl-V - notice failure}

Bug Part B;
1. Do Part A
2. Copy some text from nedit to clip board via Ctrl-C
3. Paste the text into the nedit find/replace dialog box via Ctrl-V - notice crash
  
Actual results:

A. Nedit fails to copy and paste once other applications are open which use the Ctrl-C/Ctrl-V clipboard, particularly when the clipboard is already in use by these applications or when another instance of nedit is open.
B. Nedit crashes when copying and pasting into the find/replace dialog box

Expected results:

A. Nedit can copy and paste regardless of what other applications are open (ie no clip board conflict)
B. Nedit doesnt crash when copying and pasting into find/replace dialog box


Additional info:
- This problem is most likely a Lesstif issue
- I cannot compile a working version of nedit from source from nedit.org as it is unclear which version of lesstif is required; ie it is unclear exactly which libraries they used to build the nedit executable on nedit.org. I need to be able to build a stable version of nedit because I always integrate the nedit "Save All" patch into my version of nedit.
- building a new version of nedit from the rpm src results in exactly the same bug as reported here (A. and B.)
- Note the Nedit executable from nedit.org did not work on FC6 [major scroll speed issue] but for some reason but it works on FC10.
- it has been over 2 years now without a stable version of nedit released by Fedora and I think this situation needs to change. Nedit is in my opinion the best Linux text editor (did read some unicode limitation which I dont personally care about) - regardless of my opinion, Nedit has a combination of features which does not exist in any other linux text editor (It is fast, good efficient fonts, Find, Replace, Replace all, Save All etc). (NB Textpad on wine does not support syntax highlighting so Textpad is not an option).
Comment 1 Richard Baxter 2009-04-01 02:04:42 EDT
Here is a workaround to the Fedora Project Nedit Copy/Paste Bug - 'How to Install A Working Version Of Nedit From Source'. (The first method, 1. using a nedit approved version of openmotif has been tested, the second method, 2. using a nedit approved version of lesstif has not yet been tested);


************************************************************************



1. solution "how to install nedit from source using Openmotif.txt" [not Lesstif]; 
	[nedit has been tested to compile with these versions of Openmotif; 
		ftp://ftp.ics.com/openmotif/2.2/2.2.3/src/openMotif-2.2.3.tar.gz
	theoretical/reported good versions of openmotif for nedit;
		    "2.1.30"
		    "2.2.3"
		    [see /home/rich/utilsfc10/neditsourcegood/nedit-5.5/util/check_lin_tif.c]


1. install a good version of open motif from source [eg openMotif-2.2.3]

	to compile openmotif from source;

su root
rpm -e nedit		[make sure all nedit and lesstif rpms are uninstalled]
rpm -e lesstif-devel
rpm -e lesstif
cd /home/rich/utilsfc10/neditfromsourcegood/Openmotif/
rpm -i xbase-2.0.0-13.fc10.x86_64.rpm
rpm -i xorg-x11-xbitmaps-1.0.1-6.fc10.x86_64.rpm
su rich
tar -xvf openMotif-2.2.3.tar.gz
cd openMotif-2.2.3
./configure
unset LANG 
make 
su root
make install


2. install a good version of nedit from source [eg nedit-5.5]

2a.
su root
cd /etc/
gedit ld.so.conf, and change to this;
	include ld.so.conf.d/*.conf
	include /usr/X11R6/lib
			[or wherever motif installed it's libraries to]
ldconfig	


2b.
su rich
cd /home/rich/utilsfc10/neditfromsourcegood
tar -xvf nedit-5.5-src.tar.gz	[get from nedit.org/sourceforge.net]
cd nedit-5.5
gedit makesfiles/Makefile.linux, and change to this;	{nb addition of -lXmu}

	# $Id: Makefile.linux,v 1.11 2003/05/20 00:27:56 n8gray Exp $
	CC=cc
	AR=ar

	CFLAGS=-O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD

	ARFLAGS=-urs

	#LIBS= -L/usr/X11R6/lib -Wl,-Bstatic -lXm -Wl,-Bdynamic -lXp -lXpm -lXext -lXt -lSM -lICE -lX11 -lm
	LIBS= -L/usr/X11R6/lib -Wl,-Bstatic -lXm -Wl,-Bdynamic -lXp -lXpm -lXext -lXt -lSM -lICE -lX11 -lm -lXmu

	include Makefile.common

	verify_config: check_tif_rule

{nb you may wish to patch the nedit source files before compiling, eg via 'cd source', 'patch menu.c nedit-save-all.patch' - if you are not patching source files, you may as well just download the precompiled nedit executable from nedit.org/sourceforge.net}

make 
su root
make install
cd source
su rich 
./nedit  (test it works)
su root
cp nedit /usr/bin/nedit 
cp nc /usr/bin/nc





************************************************************************




2. not yet tested solution, "how to install nedit from source using Lesstif.txt" [not Openmotif]; 
	[nedit has been tested to compile {but execution not tested} with these versions of lesstif; 
		when using http://prdownloads.sourceforge.net/lesstif/lesstif-0.93.94.tar.gz;]
		when using http://prdownloads.sourceforge.net/lesstif/lesstif-0.93.18.tar.gz;]
	theoretical/reported good versions of lesstif for nedit;
		    "0.92.32",
		    "0.93.0",
		    "0.93.12",
		    "0.93.18",
		[ see /home/rich/utilsfc10/neditsourcegood/nedit-5.5/util/check_lin_tif.c]
    
1. install a good version of lesstif from source [eg lesstif-0.93.18]

	to compile lesstif from source;

rpm -e nedit		[make sure all nedit and lesstif rpms are uninstalled]
rpm -e lesstif-devel
rpm -e lesstif
cd /home/rich/utilsfc10/neditfromsourcegood/Lesstif/
tar -xvf lesstif-0.93.18.tar.gz
cd lesstif-0.93.18 	[or lesstif-0.93.94??]
./configure
make
su root
make install

	{probably not necessary;
	link libXm.so.2.0.1 /usr/lib/libXm.so
	link libXm.so.2.0.1 /usr/lib/libXm.so.2
	ldconfig}


2. install a good version of nedit from source [eg nedit-5.5]

2a.
su root
cd /etc/
gedit ld.so.conf, and change to this;
	include ld.so.conf.d/*.conf
	include /usr/local/lib
		[or wherever lesstif installed it's libraries to]
ldconfig	


2b.
su rich
cd /home/rich/utilsfc10/neditfromsourcegood
download nedit
tar -xvf nedit-5.5-src.tar.gz	[get from nedit.org /sourceforge.net]
cd nedit-5.5
gedit makesfiles/Makefile.linux, and change to this; {nb change of -L and -I directories to /usr/local/lib ; nb this may not be required if have installed a version of lesstif from an rpm instead of from source} 

	# $Id: Makefile.linux,v 1.11 2003/05/20 00:27:56 n8gray Exp $
	CC=cc
	AR=ar

	CFLAGS=-O -I/usr/local/include/Xm -DUSE_DIRENT -DUSE_LPR_PRINT_CMD

	ARFLAGS=-urs

	LIBS= -L/usr/local/lib -Wl,-Bstatic -Wl,-Bdynamic -lXp -lXpm -lXext -lXt -lSM -lICE -lX11 -lXm -lm

	include Makefile.common

	verify_config: check_tif_rule

{nb you may wish to patch the nedit source files before compiling, eg via 'cd source', 'patch menu.c nedit-save-all.patch' - if you are not patching source files, you may as well just download the precompiled nedit executable from nedit.org/sourceforge.net}

make 
su root
make install
cd source
su rich 
./nedit  (test it works)
su root
cp nedit /usr/bin/nedit 
cp nc /usr/bin/nc
Comment 2 Richard Baxter 2009-05-14 04:20:17 EDT
Here is an updated set of FC10 nedit installation instructions - basically Nedit/Motif require a whole lot of 32 bit libraries which will not be installed by default by FC10 x64 (there might even be some extra ones required which have not added to the list here).

1. solution "how to install nedit from source using Openmotif.txt" [not
Lesstif]; 
 [nedit has been tested to compile with these versions of Openmotif; 
  ftp://ftp.ics.com/openmotif/2.2/2.2.3/src/openMotif-2.2.3.tar.gz
 theoretical/reported good versions of openmotif for nedit;
      "2.1.30"
      "2.2.3"
      [see /home/rich/utilsfc10/neditsourcegood/nedit-5.5/util/check_lin_tif.c]


1. install a good version of open motif from source [eg openMotif-2.2.3]

 to compile openmotif from source;

su root
rpm -e nedit  [make sure all nedit and lesstif rpms are uninstalled]
rpm -e lesstif-devel
rpm -e lesstif
cd /home/rich/utilsfc10/neditfromsourcegood/Openmotif/
rpm -i xbase-2.0.0-13.fc10.x86_64.rpm
rpm -i xorg-x11-xbitmaps-1.0.1-6.fc10.x86_64.rpm
rpm -i libXmu-1.0.4-1.fc9.i386.rpm  
rpm -i libXp-devel-1.0.0-11.fc9.x86_64.rpm
rpm -i libXp-1.0.0-11.fc9.i386.rpm          
rpm -i libXp-devel-1.0.0-11.fc9.i386.rpm  
rpm -i xbase-2.0.0-13.fc10.x86_64.rpm
rpm -i xorg-x11-proto-devel-7.4-5.fc10.noarch.rpm
rpm -i xorg-x11-xbitmaps-1.0.1-6.fc10.x86_64.rpm
su rich
tar -xvf openMotif-2.2.3.tar.gz
cd openMotif-2.2.3
./configure
unset LANG 
make 
su root
make install


2. install a good version of nedit from source [eg nedit-5.5]

2a.
su root
cd /etc/
gedit ld.so.conf, and change to this;
 include ld.so.conf.d/*.conf
 include /usr/X11R6/lib
   [or wherever motif installed it's libraries to]
ldconfig 


2b.
su rich
cd /home/rich/utilsfc10/neditfromsourcegood
tar -xvf nedit-5.5-src.tar.gz [get from nedit.org/sourceforge.net]
cd nedit-5.5
gedit makesfiles/Makefile.linux, and change to this; {nb addition of -lXmu}

 # $Id: Makefile.linux,v 1.11 2003/05/20 00:27:56 n8gray Exp $
 CC=cc
 AR=ar

 CFLAGS=-O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD

 ARFLAGS=-urs

 #LIBS= -L/usr/X11R6/lib -Wl,-Bstatic -lXm -Wl,-Bdynamic -lXp -lXpm -lXext -lXt
-lSM -lICE -lX11 -lm
 LIBS= -L/usr/X11R6/lib -Wl,-Bstatic -lXm -Wl,-Bdynamic -lXp -lXpm -lXext -lXt
-lSM -lICE -lX11 -lm -lXmu

 include Makefile.common

 verify_config: check_tif_rule

{nb you may wish to patch the nedit source files before compiling, eg via 'cd
source', 'patch menu.c nedit-save-all.patch' - if you are not patching source
files, you may as well just download the precompiled nedit executable from
nedit.org/sourceforge.net}

make 
su root
make install
cd source
su rich 
./nedit  (test it works)
su root
cp nedit /usr/bin/nedit 
cp nc /usr/bin/nc
Comment 3 Richard Baxter 2009-05-21 02:41:09 EDT
(so if necessary, type 'yum install packagename/packagename.i386/libraryname' to install any missing .rpm pacakges / 32 bit .rpm packages / . so libraries)
Comment 4 Richard Baxter 2009-07-30 02:12:45 EDT
Here is an updated set of FC10 nedit installation instructions - basically
Nedit/Motif require a whole lot of 32 bit libraries which will not be installed
by default by FC10 x64 (there might even be some extra ones required which have
not added to the list here). It is assumed FC10 has been installed from DVD with the Development option selected. Any RPMS missing from the new set of pre-requisite rpms contained below should be provided by installing adobereader 8.1.3, wine, gdl or xmms.

1. solution "how to install nedit from source using Openmotif.txt" [not
Lesstif]; 
 [nedit has been tested to compile with these versions of Openmotif; 
  ftp://ftp.ics.com/openmotif/2.2/2.2.3/src/openMotif-2.2.3.tar.gz
 theoretical/reported good versions of openmotif for nedit;
      "2.1.30"
      "2.2.3"
      [see /home/rich/utilsfc10/neditsourcegood/nedit-5.5/util/check_lin_tif.c]


1. install a good version of open motif from source [eg openMotif-2.2.3]

 to compile openmotif from source;

su root
rpm -e nedit  [make sure all nedit and lesstif rpms are uninstalled]
rpm -e lesstif-devel
rpm -e lesstif
cd /home/rich/utilsfc10/neditfromsourcegood/Openmotif/
rpm -i xbase-2.0.0-13.fc10.x86_64.rpm
rpm -i xorg-x11-xbitmaps-1.0.1-6.fc10.x86_64.rpm
rpm -i libXmu-1.0.4-1.fc9.i386.rpm  
rpm -i libXp-devel-1.0.0-11.fc9.x86_64.rpm
rpm -i libXp-1.0.0-11.fc9.x86_64.rpm
rpm -i libXp-1.0.0-11.fc9.i386.rpm          
rpm -i libXp-devel-1.0.0-11.fc9.i386.rpm  
rpm -i xbase-2.0.0-13.fc10.x86_64.rpm
rpm -U xorg-x11-proto-devel-7.4-5.fc10.noarch.rpm
rpm -i xorg-x11-xbitmaps-1.0.1-6.fc10.x86_64.rpm
rpm -i xorg-x11-fonts-misc-7.2-6.fc9.noarch.rpm
rpm -i xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch.rpm
su rich
tar -xvf openMotif-2.2.3.tar.gz
cd openMotif-2.2.3
./configure
unset LANG 
make 
su root
make install


2. install a good version of nedit from source [eg nedit-5.5]

2a.
su root
cd /etc/
gedit ld.so.conf, and change to this;
 include ld.so.conf.d/*.conf
 include /usr/X11R6/lib
   [or wherever motif installed it's libraries to]
ldconfig 


2b.
su rich
cd /home/rich/utilsfc10/neditfromsourcegood
tar -xvf nedit-5.5-src.tar.gz [get from nedit.org/sourceforge.net]
cd nedit-5.5
gedit makesfiles/Makefile.linux, and change to this; {nb addition of -lXmu}

 # $Id: Makefile.linux,v 1.11 2003/05/20 00:27:56 n8gray Exp $
 CC=cc
 AR=ar

 CFLAGS=-O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD

 ARFLAGS=-urs

 #LIBS= -L/usr/X11R6/lib -Wl,-Bstatic -lXm -Wl,-Bdynamic -lXp -lXpm -lXext -lXt
-lSM -lICE -lX11 -lm
 LIBS= -L/usr/X11R6/lib -Wl,-Bstatic -lXm -Wl,-Bdynamic -lXp -lXpm -lXext -lXt
-lSM -lICE -lX11 -lm -lXmu

 include Makefile.common

 verify_config: check_tif_rule

{nb you may wish to patch the nedit source files before compiling, eg via 'cd
source', 'patch menu.c nedit-save-all.patch' - if you are not patching source
files, you may as well just download the precompiled nedit executable from
nedit.org/sourceforge.net}

make linux
cd source
su root
cp nedit /usr/bin/nedit
Comment 5 Joachim Frieben 2009-08-03 09:25:37 EDT
Having neither 'acroread' nor 'firefox' installed, I have tried to reproduce the issue using 'epiphany' and multiple windows of 'nedit'. Everything seems to behave normally. Installed Motif library is lesstif-0.95.2-1.fc12.x86_64.
Comment 6 Richard Baxter 2009-09-15 03:07:50 EDT
I can confirm this copy/paste issue occurs on Red Hat Enterprise 5.3 also (with nedit-5.5-21.el5.x86_64.rpm, libXp-1.0.0-8.1.el5.x86_64.rpm, openmotif-2.3.1-2.el5.x86_64.rpm). Unfortunately the above solution provided to compile a working version of nedit for FC10 does not resolve the issue for EL5. Note the following pre-requisite packages should be used when trying to reinstall nedit from source on EL5;

	rpm -i libXp-1.0.0-8.1.el5.i386.rpm
	rpm -i libXp-1.0.0-8.1.el5.x86_64.rpm
	rpm -i libXp-devel-1.0.0-8.1.el5.i386.rpm
	rpm -i libXp-devel-1.0.0-8.1.el5.x86_64.rpm
	rpm -i xbase-2.0.0-6.el5.i386.rpm
	rpm -i xbase-2.0.0-6.el5.x86_64.rpm
	rpm -i xorg-x11-proto-devel-7.1-9.el5.centos.i386.rpm
	rpm -i xorg-x11-xbitmaps-1.0.1-4.1.x86_64.rpm
		may also be required (already installed on my system);
		libXp-1.0.0-8.1.el5.x86_64.rpm
		libXp-1.0.0-8.1.el5.i386.rpm
		libXmu-1.0.2-5.x86_64.rpm
		libXmu-1.0.2-5.i386.rpm
		libXmu-devel-1.0.2-5.x86_64.rpm
		libXmu-devel-1.0.2-5.i386.rpm
		xorg-x11-fonts-misc-7.1-2.1.el5.noarch.rpm
		xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5.noarch.rpm
		
The nedit executable from nedit.org can be used on EL5 to avoid this issue.
Comment 7 Joachim Frieben 2009-09-15 04:55:23 EDT
I cannot confirm this issue for an i686 F11 system on which I have rebuilt package openmotif-2.3.2-1.el5 and nedit-5.5-21.fc11, the latter of course after adapting the spec file in order to build against openmotif instead of lesstif.
Make sure your nedit binary has actually been built again Open Motif, preferably by removing lesstif and lesstif-devel from your system as the first step, and that it does link against the real Open Motif libraries (ldd /usr/bin/nedit):

$ ldd /usr/bin/nedit
	linux-gate.so.1 =>  (0x00593000)
	libXm.so.4 => /usr/lib/libXm.so.4 (0x00101000)
	libXmu.so.6 => /usr/lib/libXmu.so.6 (0x00dc4000)
	libXp.so.6 => /usr/lib/libXp.so.6 (0x00832000)
	libXpm.so.4 => /usr/lib/libXpm.so.4 (0x031c6000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x00a6a000)
	libXt.so.6 => /usr/lib/libXt.so.6 (0x055d1000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x00df2000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x02efe000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x008d3000)
	libm.so.6 => /lib/libm.so.6 (0x00765000)
	libc.so.6 => /lib/libc.so.6 (0x005f2000)
	libXft.so.2 => /usr/lib/libXft.so.2 (0x0562e000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00c2c000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00bf6000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00b39000)
	libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x03515000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00bcd000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x00a22000)
	libuuid.so.1 => /lib/libuuid.so.1 (0x00dec000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00a04000)
	libdl.so.2 => /lib/libdl.so.2 (0x0078f000)
	/lib/ld-linux.so.2 (0x005ce000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x00a89000)
	libz.so.1 => /lib/libz.so.1 (0x007b3000)
Comment 8 Richard Baxter 2009-09-15 06:01:05 EDT
Thanks for your quick feedback.

I can confirm Nedit is being built against Open Motif - 1) I am ensuring it mentions this during the nedit make process, 2) and I am ensuring that lesstif and lesstif-devel is not installed.

Note that I would expect your findings (nedit works on FC11 with openmotif) since nedit on FC10 with openmotif works via my above compilation method, and your modified rpm installation method is probably very similar. I would assume your installation method would work on FC10 also.

Note my previous statement, "The nedit executable from nedit.org can be used on EL5 to avoid this issue" is incorrect. I can confirm the nedit binary from nedit.org when used on EL5 has this same bug. (On FC10 [and I assume FC11], it works however). 

I am going to have a go at installing nedit on EL5 using the "openmotif-2.3.2-1.el5" rpm instead of my 2.2.3 tar.gz source version of open motif. (based upon your results, maybe this will work).

Richard
Comment 9 Richard Baxter 2009-09-15 07:28:19 EDT
"I am going to have a go at installing nedit on EL5 using the openmotif-2.3.2-1.el5" - actually, I am sure this will not work either, since the EL5 rpm version of nedit provided by Redhat uses openmotif-2.3.2-1.el5 anyway and it does not work. (If you have time, please try installing firefox - it should only take a few minutes to replicate this issue).
Comment 10 Richard Baxter 2009-09-17 08:58:51 EDT
"The nedit executable from nedit.org can be used on EL5 to avoid this issue" - this appears in fact to be correct. (I was receiving some false negatives probably because I was not restarting my system between nedit version tests). This seems like a reasonable interim solution.
Comment 11 Richard Baxter 2009-10-05 06:20:11 EDT
"Note the Nedit executable from nedit.org did not work on FC6 [major scroll
speed issue] but for some reason but it works on FC10." - the nedit binary from nedit.org has a major scroll issue on both FC6 i386 and EL5 i386, but it does not have this issue on FC10 x64, or EL5 x64 (, or I assume FC6 x64 either however have not tested this). Therefore there appears to be no working nedit solution for a >=2006 i386 redhat based operating systems. 

(Note there appears to be workarounds available for x64bit redhat operating systems as discussed above. The easiest work around is to install the nedit binary from nedit.org [works for at least EL5 and FC10]. For references, there is also a known recompilation method for nedit on FC10 x64 that produces a working version of nedit subject to the particular openmotif source version).

It is suggested that nedit is thoroughly tested in a modern environment (with at least Firefox installed) before being released by either Fedora or Enterprise Linux. This exact bug appears to have been around now for over 3 years.
Comment 12 Richard Baxter 2009-11-01 00:11:27 EDT
Note I am also not sure if nedit as distributed by Fedora was working on FC3 i386 - it was definitely working on FC3 x64. Here is an update on what I have experienced;

Key:
bugA = Bug Part A = copy/paste bug (see description of problem above)
bugB = Bug Part B = extreme copy/paste bug (nedit crashes when copying and pasting in nedit find window) (see description of problem above)
slow = (see description of problem above)
ok = no copy/paste related bugs found
? assume = untested by self

Distro		i386nedit.rpm	i386nedit.org	x64nedit.rpm	x64nedit.org
FC3		? assume bug	? assume slow	ok (old FF)	? assume ok
FC6		bugA+B		slow		? assume bugA+B	? assume ok
FC10		? assume bugA+B	? assume slow	bugA+B		ok	
EL5		bugA		slow		bugA		ok	

NB nedit from nedit.org uses motif/openmotif (not lesstif)
NB nedit from rpm uses Lesstif from FC3 to FC10, but uses openmotif in EL5
Comment 13 Richard Baxter 2009-11-01 00:12:40 EDT
Distro  i386nedit.rpm   i386nedit.org  x64nedit.rpm    x64nedit.org
FC3     ? assume bug    ? assume slow  ok (old FF)     ? assume ok
FC6     bugA+B          slow           ? assume bugA+B ? assume ok
FC10    ? assume bugA+B ? assume slow  bugA+B          ok	
EL5     bugA            slow           bugA            ok
Comment 14 Joachim Frieben 2009-11-01 03:37:22 EST
Given that FC 1-5 provided package openmotif as primary implementation of Motif, I am not surprised that nedit used to work for these releases. From FC6 on, only lesstif survived in the Fedora (Core/Extras) package pool which makes the failure explainable.
I will try to reproduce your results for CentOS 5.4 and give feedback thereafter.
Comment 17 RHEL Product and Program Management 2010-04-13 09:27:11 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 18 Richard Baxter 2010-04-13 10:51:34 EDT
It would be nice to get some feedback on this issue as it does not take very long to replicate under the stated circumstances. 

However, assuming this bug is not to be fixed and users wish to still use nedit as their default text/code editor, may I suggest one of the following:

a) use the nedit rpm from the EL5 repository, only open a single nedit window, and stay away from firefox and acrobat reader (and probably all other gnome applications completely such as gnome-terminal)
b) install 64bit EL5 and use the nedit executable from nedit.org [RECOMMENDED]

Note that the nedit executable from nedit.org will work on a 64bit EL5 system  near perfectly, but the previously tabulated result of 'ok' is in fact incorrect. Nedit will start to suffer from bug A if put under extreme circumstances (Eg 3 nedit processes started at different times, 60 nedit windows open, multiple copy and pasting between nedit and non nedit windows. See the history of the testing of this scenario from my previous posts, Comment 6, Comment 8 and Comment 10 ("The nedit executable from nedit.org can be used on EL5 to avoid this issue").

Cheers,

Richard

Note You need to log in before you can comment on or make changes to this bug.