Bug 493035 - time spent waiting for password contributes to progress bar
time spent waiting for password contributes to progress bar
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 08:11 EDT by Michal Schmidt
Modified: 2009-07-01 07:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 07:33:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2009-03-31 08:11:37 EDT
Description of problem:
I have my root filesystem encrypted. Plymouth asks for the password early in the boot process. When I enter the password quickly, the progress bar starts correctly near the left side of the screen and grows to the right. If however I take my time to enter the password, the progress bar is already very long when it reappears.

Version-Release number of selected component (if applicable):
plymouth-0.7.0-0.2009.03.10.2.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. Use an encrypted root filesystem. Start booting.
2. Go make tea. Or coffee. Or love.
3. Return and notice plymouth's password prompt.
4. Enter the password.

Actual results:
The progress bar reappears and it covers almost the whole width of the screen already. That's because the time you spent at step 2 has been accounted as boot progress.

Expected results:
The progress bar should reappear and be still very short, because we're not really that far in the boot process. Time spent waiting for user input should not be accounted as progress.
Comment 1 Charlie Brej 2009-03-31 17:30:30 EDT
That one is my fault. I made the pausing optional but made the default to not pause. Reversed to pause by default and pushed to the upstream git.

http://cgit.freedesktop.org/plymouth/commit/?id=cfeb45e1d3179cfb4c140d0f74d90c27bce383bc

When not paused it reaches the next event it expects and turns to crawl speed which takes like 3 minutes to complete so I forgot about this and didn't notice (especially as all the activities you state in step 2 take less than 3 minutes).
Comment 2 Bug Zapper 2009-06-09 08:50:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Thomas Janssen 2009-07-01 05:28:34 EDT
That one seems to be fixed in rawhide x86_64. The progress bar acts as it should after 2 minutes coffee break.

Is it fixed for you too?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Michal Schmidt 2009-07-01 07:33:21 EDT
Looks fixed in plymouth-0.7.0-0.2009.05.15.1.fc11.x86_64 too. Thanks.

Note You need to log in before you can comment on or make changes to this bug.