This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 493039 - Start-up ordering causes NFS serving export list failure
Start-up ordering causes NFS serving export list failure
Status: CLOSED DUPLICATE of bug 475133
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 08:28 EDT by Bevis King
Modified: 2009-06-11 11:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 11:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2009-03-31 08:28:12 EDT
Description of problem:
When NFS serving from Fedora 10 to clients on the local network, initial exportfs fails because named running on the same server is not being used for lookups correctly.  The scenario is that IP addresses for NFS client hosts on the local network are listed in the local domain server (named) tables.  Due to the start order/timing issues, when exportfs is run as part of /etc/init.d/nfs start, the named is not being referred to yet and the exportfs command rejects all clients on the local subnet as having "non-inet address" (yet) and fails to enter them into the kernel NFS exports table.  Re-running exportfs after server machine has finished booting, exportfs can now resolve the names using named and they get added to the export list for the NFS server.

The issue is that the as-shipped system will not boot into an operational NFS server/named server due to this problem.

Version-Release number of selected component (if applicable):
initscripts-8.86-1.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1.  Export some NFS filesystems to hosts identified by names that only appear
    in the local name server tables.
2.  Reboot the system
3.  NFS clients will fail to mount with Permission Denied despite being listed
    in the /etc/exports file due to startup ordering/timing issues.
  
Actual results:
NFS clients get Permission Denied on the mount.

Expected results:
NFS clients get granted access if listed in /etc/exports.

Additional info:
Comment 1 iarly selbir 2009-03-31 09:00:46 EDT
If you add the hostname in /etc/hosts, the problem happen?

I don't tried to reproduce.

Thanks.
Comment 2 Bevis King 2009-03-31 10:56:06 EDT
I'll try adding one of the NFS clients but not the others, rebooting and reporting back on progress.  Will probably be tomorrow evening before I can do that without interrupting user service.

Regards, Bevis.
Comment 3 Steve Dickson 2009-06-11 11:08:48 EDT

*** This bug has been marked as a duplicate of bug 475133 ***

Note You need to log in before you can comment on or make changes to this bug.