Bug 493049 - Can't import pst-files in Evolution
Can't import pst-files in Evolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 09:37 EDT by Espen Stefansen
Modified: 2009-07-28 13:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-2.27.5-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 13:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (24.83 KB, patch)
2009-06-20 03:18 EDT, ritz
no flags Details | Diff

  None (edit)
Description Espen Stefansen 2009-03-31 09:37:19 EDT
Description of problem:
I can't import pst-files in evolution. I choose "import" and select the pst-file. The importer doesn't recognize the filetype and i can't continue.

I looked at the source and AFAIK there should be a pst-import plugin, but it's not included in the fedora rpm.

Version-Release number of selected component (if applicable):
evolution-2.26.0-1.fc11.i586
evolution-data-server-2.26.0-1.fc11.i586
Comment 1 Matthew Barnes 2009-04-10 11:04:39 EDT
Will be happy to enable this feature as soon as Fedora gets a library for reading PST files.  I believe libpst-0.6.35 will grow an actual library.
Comment 2 Bug Zapper 2009-06-09 08:50:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Zdravko Nikolov 2009-06-17 06:36:31 EDT
I was able to convert a .pst file to mbox with readpst.

libpst-libs-0.6.36-1.fc11.i586
libpst-0.6.36-1.fc11.i586


So it looks to me that fedora has this incorporated and the plugin should be enabled!
Comment 4 ritz 2009-06-19 16:34:24 EDT
BuildRequires would need libpst-devel, and libytnef-devel paclage, to allow the plugins to be built in.

-- ritz
Comment 5 ritz 2009-06-20 03:18:21 EDT
Created attachment 348735 [details]
patch based on upstream code

We also need to add -
http://bugzilla.gnome.org/show_bug.cgi?id=578945

patch built against evolution-2.27.3 .
Comment 6 Matthew Barnes 2009-07-02 17:17:33 EDT
Patch is already outdated against libpst 0.6.41.

libpst has no API stability right now and it's not worth trying to chase.
Once it settles down I'll enable the Evolution plugin.
Comment 7 Milan Crha 2009-07-28 13:46:02 EDT
Back enabled in 2.27.5-3, as Matt told me. Thus closing as such.

Note You need to log in before you can comment on or make changes to this bug.