Bug 493056 - Service Breach Time Not Populated
Service Breach Time Not Populated
Status: CLOSED NOTABUG
Product: JBoss Customer Support Portal
Classification: Retired
Component: Gatekeeper (Show other bugs)
MR15
All Linux
low Severity high
: ---
: ---
Assigned To: JBoss CSP Bug Watch List
:
Depends On:
Blocks: 523261
  Show dependency treegraph
 
Reported: 2009-03-31 10:00 EDT by Mike Millson
Modified: 2010-10-23 04:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 15:16:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Millson 2009-03-31 10:00:24 EDT
Service breach time field is not populated on these cases:
1) https://enterprise.redhat.com/issue-tracker/280894
2) https://enterprise.redhat.com/issue-tracker/278977
Comment 1 Tom Mirc 2009-04-13 13:17:52 EDT
Need further analysis and a determination of root cause.  May be related to existing issues or indicative of other issues.
Comment 2 Nathan Lugert 2009-04-20 14:40:21 EDT
I have found out why Service Breach times are not being set by GK.

Initial Response Time is "None" for the cases not being set.  Initial Response Times and Subsequent Response Times are set in SEP for each product/sku. Default is "None" in the CSP code.

Here is a code snippet for when we set it on the ticket

if (ticket.getProduct() != null) {
           AccessRights rights = entitlementBean.getAccess(customer);
           ProductEntitlement entitlement = rights.getProduct(ticket.getProduct());
           if (entitlement != null) {
               ticket.setServiceLevel(entitlement.getServiceLevel());
               if (severityLevel.equals("1"))
               {
                   ticket.setInitialResponseTime(entitlement.getInitialSev1());


Service level is set so we are getting to "ticket.setServiceLevel(entitlement.getServiceLevel()". So, my guess is that these times are not being set on products/skus in SEP. I know Lee Mewshaw used to manage these, not sure if anyone took that over.
Comment 3 Lami Akagwu 2009-04-24 05:46:12 EDT
We have a severity 1 ticket https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=288719&gid=1354 which had the wrong service breach time populated.
For a ticket opened around 22:30 23/04/2009 BST, as at 09:00 24/04/2009 BST the service breach time was over 6hours.
Comment 4 Nicole Yancey 2009-09-11 16:33:08 EDT
Moving to MR15
Comment 5 Nathan Lugert 2009-11-30 15:16:59 EST
Closing this bug as the corresponding I-T Tickets have been closed.

Note You need to log in before you can comment on or make changes to this bug.