Bug 493060 - monitoring email, Subject: RHN Monitoring Scout started
monitoring email, Subject: RHN Monitoring Scout started
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Petr Sklenar
: ReleaseNotes, Reopened, Triaged
Depends On:
Blocks: sat540-canfix
  Show dependency treegraph
 
Reported: 2009-03-31 10:05 EDT by wes hayutin
Modified: 2010-10-28 10:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-31 10:05:44 EDT
Description of problem:
Satellite-5.3.0-RHEL5-re20090327.0-i386-embedded-oracle.iso

apparently this is a bug =)  I had no idea.

From: 	HTTPS-MX@redhat.com
To: 	whayutin@redhat.com
Subject: 	RHN Monitoring Scout started
Date: 	Wed, 25 Mar 2009 12:16:57 -0400


Monitoring Scout configuration successful on grandprix.rhndev.redhat.com


<< Sent by /usr/bin/npBootstrap.pl line 116 on host grandprix.rhndev.redhat.com (MAC 00:16:3E:52:D4:EA). >>
Comment 1 wes hayutin 2009-03-31 10:06:48 EDT
users should NOT receive this email
Comment 2 Clifford Perry 2009-03-31 11:09:44 EDT
This is not a bug, I get these in 4.x and 5.x Monitoring. 

Who said it was a bug? :) 

Closing out.
Comment 3 Mike McCune 2009-03-31 11:51:37 EDT
I did. this email is annoying and largely useless.  Why should one of the many services spam the admin every time it starts!?
Comment 4 Vlady Zlatkin 2009-03-31 11:53:32 EDT
I agree with Mike and so does a customer next to whom I am sitting.
Comment 5 Miroslav Suchý 2009-07-23 08:50:09 EDT
I done it in spacwalk in commit 8b5b5c0e4fff24c28aae8687d2d45bbaf7d9655d.
However I do not recommend it to backport to 530 (it have some requirements which are not in 530). Leaving for next release.

Now is new option notify_scout_start available in file /etc/rhn/cluster.ini. It is by default set to 0, which means: do not send email on successfull scout start. When set to 1, old behavior is restored, i.e. email is sent. 
If Scout fails to start email is sent no matter what value is set.
Comment 7 Miroslav Suchý 2010-09-14 14:31:20 EDT
Present on Satellite-5.4.0-RHEL5-re20100910.2
moving ON_QA
Comment 8 Petr Sklenar 2010-09-21 12:31:39 EDT
test procedure:
1. enable monitoring
2. rhn-satellite restart
3. see mail

result:
sat530: 'RHN Monitoring Scout started'
sat540: no mail about scout starting
--
verified with Satellite-5.4.0-RHEL5-re20100910.2
Comment 9 Tomas Lestach 2010-10-27 06:46:07 EDT
I followed the test scenario from Comment#8 and I received no email notifying start of monitoring scout.

STAGE VALIDATED on Satellite-5.4.0-RHEL5-re20101025.0
Comment 10 Clifford Perry 2010-10-28 10:50:44 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.