Bug 493129 - netcat uses inefficient socket read sizes
netcat uses inefficient socket read sizes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 14:08 EDT by Aron Griffis
Modified: 2009-04-10 09:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 09:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
double read sizes to accomodate full-size packets (761 bytes, patch)
2009-03-31 14:08 EDT, Aron Griffis
no flags Details | Diff

  None (edit)
Description Aron Griffis 2009-03-31 14:08:05 EDT
Created attachment 337367 [details]
double read sizes to accomodate full-size packets

Description of problem:
netcat uses read sizes of 1024 for standard packets and 8192 for jumbos.  This doesn't make sense because standard packets are ~1518 bytes and jumbos typically max out ~9018, so full-size packets will result in twice the necessary read syscalls.

Version-Release number of selected component (if applicable):
nc-1.84-18.fc11

Additional info:
This bug is also present upstream at 
http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/netcat.c?rev=1.92;content-type=text%2Fplain
Comment 1 Jan Zeleny 2009-04-10 09:16:05 EDT
Patch has been included in rawhide package, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.