Bug 49317 - After upgrade to kernel 2.4.3-12 usb-controller does not initialize
After upgrade to kernel 2.4.3-12 usb-controller does not initialize
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-17 19:09 EDT by oliver
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 14:12:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver 2001-07-17 19:09:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-12 i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
After applying the kernel upgrade to 2.4.3-12 as described on
the Redhat errata page the USB Controller fails to initialize 
when the system is starting up. 

How reproducible:
Always

Steps to Reproduce:
1.Boot the system
2.
3.
	

Actual Results:  USB initialization fails with error message

Expected Results:  No error and working USB

Additional info:

Lines from /var/log/messages:

Jul 18 00:28:37 hoelderlin modprobe: Hint: insmod errors can be caused by
incorrect module parameters, including invalid IO or IRQ parameters 
Jul 18 00:28:44 hoelderlin kernel: Winbond Super-IO detection, now testing
ports 3F0,370,250,4E,2E ...
Jul 18 00:28:37 hoelderlin modprobe:
/lib/modules/2.4.3-12/kernel/drivers/usb/usb-ohci.o: init_module: No such
device 
Jul 18 00:28:44 hoelderlin kernel: Winbond chip at EFER=0x3f0 key=0x87
devid=52 devrev=f4 oldid=ff
Jul 18 00:28:37 hoelderlin modprobe:
/lib/modules/2.4.3-12/kernel/drivers/usb/usb-ohci.o: insmod
/lib/modules/2.4.3-12/kernel/drivers/usb/usb-ohci.o failed 
Jul 18 00:28:44 hoelderlin kernel: Winbond chip type 83977EF / SMSC 97w35x
Jul 18 00:28:37 hoelderlin modprobe:
/lib/modules/2.4.3-12/kernel/drivers/usb/usb-ohci.o: insmod usb-ohci failed 

Mainboard: Gigabyte GA-7IXE4 (AMD Irongate Chip-Set)
CPU: Duron 800Mhz
RAM: 256MB
2 ISA slots used: Modem and AHA 1505 SCSI adaptor 
Graphics: ATI Expert 98 (Rage Pro)
Network: Linksys 100LX

Full dmesg at
http://na.uni-tuebingen.de/~oliver/dmsg

Bigger slice of /var/log/messages:
http://na.uni-tuebingen.de/~oliver/messages
Comment 1 Arjan van de Ven 2001-07-18 06:17:50 EDT
"usb-ohci.c: 00:07.4 (Advanced Micro Devices [AMD] AMD-756 [Viper]
USB):                    blacklisted, erratum #4"

AMD has released an defectsummar^Werratum that states that your specific chipset
has a defective USB chip. It will appear to work but cause LOADS of problems if
used. (lost interrupts, infinite interrupts etc etc)

Comment 2 oliver 2001-07-18 06:45:11 EDT
I should remark that before the upgrade I was able to do useful
work with USB, now I am not.  In fact I didn't even notice that
there was something wrong with the USB controller.  How about
a warning like "don't send vital data via USB", rather than
blacklisting it altogether?

Also, I specifically upgraded the kernel because it fixes those
scary mtrr related warnings with the AMD Irongate Chipset.
So it would be nice to finally have a flawless kernel for this Chipset.
Comment 3 rehbein 2002-01-21 09:44:24 EST
My problem is similar and more basic. I have a sony vaio fx370 laptop.
Originaly I installed 7.2 and immediately upgraded the kernel to
2.4.9-13. A appeared to work "except" nothing on the USB port. 
The USB port was recognized and the basic drivers were loaded. However, when
I attached any usb device an error was always reported in the log that
the USB device wouldn't accept new address (i.e. it was timing out).
The /proc/interrupts count wasn't increasing.
To insure it wasn't the laptop I loaded XP, verified the USB ports and
reloaded 7.2. I discovered with the default kernel 2.4.7-10, low 
and behold the USB and sound worked perfectly. I could use my USB based
printer and cd-writer. So, I upgrade again to 2.4.9-13 (using up2date)
and once again everything broke. However, this time I had kept
around the 2.4.7-10 kernel. Once again after booting 2.4.7-10 all worked.
There is definitely a problem with the updated kernel with USB.
Comment 4 Pete Zaitcev 2002-01-21 15:01:33 EST
We must not keep bugs NEW for months, assigning to myself.

Evidently, 2.4.7-10 used a different table somewhere.
I'll work with bug reporters to dump their $PIRQ and MPTABLE
as appropritate and see what's up. Well, hopefuly.. :)
Comment 5 Pete Zaitcev 2002-04-04 14:00:24 EST
I would appreciate if both of you guys did this:
1. boot with ok kernel and do "dmesg > /tmp/dmesg.2.4.7-10.ok"
2. boot with broken kernel and do "dmesg > /tmp/dmesg.2.4.9-xx.bad"
3. Attach both dmesg outputs to the bug
(please DO NO DROP INTO COMMENTS BOX)

If you are on 2.4.9-31 now, that would be helpful too
(it does not fix anything AFAIK, but it would be one
less diff session for me)
Comment 6 Pete Zaitcev 2002-06-04 16:16:56 EDT
Marcel Oliver (requestor) reported success with 2.4.9-21.

Note You need to log in before you can comment on or make changes to this bug.