Bug 493182 - kernel panic: not syncing: VFS: unable to mount root fs on unknown-block(9.2)
kernel panic: not syncing: VFS: unable to mount root fs on unknown-block(9.2)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 17:09 EDT by ray hammond
Modified: 2011-01-22 17:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ray hammond 2009-03-31 17:09:58 EDT
Description of problem:
kernel panic while trying to install Fedora 11 Alpha

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create a new VMWare Image in VMWare Workstation 6. Used the following default options 1024 MB RAM, 8GB HDD, CD/DVD, Floppy, LAN (NAT), USB Controller, Sound Card, Display and 1 processor.

2.Booted from ISO image.
  
Actual results:
kernel panic: not syncing: VFS: unable to mount root fs on unknown-block(9.2)

Expected results:
The installation should begin to prompt me for various settings.

Additional info:
I have used VMWare to test Fedora since Fedora Core 4 and it was worked without any problem.
Comment 1 Chuck Ebbert 2009-04-01 01:23:41 EDT
Can you capture the kernel boot log and attach it?
Comment 2 Bug Zapper 2009-06-09 08:53:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 albert 2009-07-01 03:37:26 EDT
Error during first stage of installation.
kernel panic: not syncing: VFS: unable to mount root fs on unknown-block(202,17)
I'm trying to install from downloaded Fedora-11-x86_64-DVD.iso (not beta)
PC: HP Proliant ML110G4 Server (Xeon CPU)
Currently installed Fedora 10 (32bit)
Comment 4 Aleksandar Kostadinov 2009-07-02 01:35:01 EDT
I'm seeing the same when trying to boot already installed fedora11 PV guest on RHEL 5.3 (updated to latest) xen host.
Comment 5 Aleksandar Kostadinov 2009-07-02 01:37:09 EDT
both host and guest are x86_64
Comment 6 Aleksandar Kostadinov 2009-07-27 09:32:01 EDT
It seems like my first installation attempts didn't complete correctly. In a third attempt everything seems to be working. It's odd that install process failed without notifying me anything is wrong. As well I don't see a big difference between my third attempt and the other two and why the first two failed.
Comment 7 William Washco 2009-08-26 13:34:07 EDT
Same issue, but after install on my Thinkpad T41.

When booting normally:
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)

When booting to grub command line:
grub> root (hd0,0)
grub> kernel /boot/vmlinux-2.6.31-0.174.rc7.git2.fc12.i686
grub> initrd /boot/initrd-generic-2.6.31-0.174.rc7.git.fc12.i686.img
grub> boot

A wall of text that I can't scroll through flies by. The last screen shown has this:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Freeing unused kernel memory: 1764k freed
Write protecting the kernel text: 5260k
Write protecting the kernel read-only data: 1772k
mknod used greatest stack depth: 6760 bytes left
mknod used greatest stack depth: 6760 bytes left
mknod used greatest stack depth: 6760 bytes left
dracut: dracut-0.9-2.fc12
dracut: dracut-0.9-2.fc12
dracut: FATAL: No or empty root= argument
dracut: Refusing to continue
dracut: FATAL: No or empty root= argument
dracut: Refusing to continue


Signal caught!

Boot has failed, sleeping forever.
Synaptics Touchpad, model: 1, fw:5.9, id: 02c6ab1, caps 0x884793/0x0
serio: Synaptics pass-through port at isa0060/serio1/input0
input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input5
async/1 used greatest stack depth: 5872 bytes left
IBM TrackPoint firmware: 0x0e, buttons: 3/3
input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio2/input/inpu
t6
_
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tried my best to copy it as exactly as possible, and I would have more info if I could scroll up. Hope it helps.
Comment 8 JP Mattia 2009-09-22 11:48:14 EDT
Same issue: Dell 4600, Fedora11 CDs from torrent.

Reinstalled, problem disappeared.

IIRC: The difference between the two installs:

1.  For the failed install, I checked the additional repository boxes.
2.  Checked "configure now" for the successful install, during the software selection.

No chance to try reproducing to figure out if either option is causing the issue, the machine is needed.
Comment 9 Bug Zapper 2010-04-27 09:23:43 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2010-06-28 07:37:08 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.