Bug 493195 - Wrong architecture detected on upgrade from F10
Wrong architecture detected on upgrade from F10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 17:40 EDT by Jeff Guerdat
Modified: 2009-05-20 23:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 13:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Guerdat 2009-03-31 17:40:45 EDT
Description of problem:

Toshiba Satellite A105 laptop.  Trying to install F11 Beta.  Chose to upgrade existing F10 installation but got error that existing i386 installation doesn't match i586 detected and install would likely fail.  Aborted install.

Version-Release number of selected component (if applicable):

F11 Beta

How reproducible:

Every install attempt.

Steps to Reproduce:
1. Boot from i386 DVD install media
2. Choose to upgrade existing F10 installation
3. Wait for check of existing install and get error
  
Actual results:

Always get error even though i686 should have been detected.  Chicken to try to continue so abort.

Expected results:

Detect proper architecture and install.

Additional info:

Downloaded a second DVD ISO with same result.
Comment 1 Walter Francis 2009-03-31 21:54:30 EDT
I have an up to date F10 32 bit install, upgrading to F11 Beta 32 bit install, and I see the same message (which is why I am here), but the install continues if you instruct it to continue.  So far the install is proceeding normally from there, so this seems like a warning which should be suppressed as surely 32 bit upgrades are supported.
Comment 2 Chris Lumens 2009-04-01 10:47:48 EDT
In this case, the warning message is meaningless and should be getting suppressed.  I'll take a look at why it's not.
Comment 3 Chris Lumens 2009-04-01 13:18:39 EDT
Oh sorry, I did already fix this.  However, it's not in the beta due to trying to minimize last minute changes.  It will be fixed in the next build of anaconda in rawhide.  In the meantime, you can ignore the warning message.  It's only there to protect against x86_64 <-> i386 upgrade mistakes.
Comment 4 Walter Francis 2009-05-02 15:55:53 EDT
Is this fixed really?  It's in the F11 Preview, and this last "is fixed" report is from 4/1.
Comment 5 Jeff Guerdat 2009-05-02 17:57:49 EDT
I can say it's different.  I did an upgrade initially which gave me the mismatch error.  Performing a clean install of the Preview gave me a PAE kernel which nothing before had ever offered (~2006 vintage Toshiba Satellite A105, Centrino 1.7GHz. single core CPU, 2GB RAM).  Not sure how to correlate the differences in installation.
Comment 6 Walter Francis 2009-05-02 20:32:41 EDT
This does not happen on a *clean* install, only on an upgrade from F10.  Did I misunderstand you, Jeff?
Comment 7 Jeff Guerdat 2009-05-02 21:04:10 EDT
Correct.  I initially updated F10 via the beta release and had an error that the architecture mismatched i386 vs. i586).  Installation disregarding the warning went fine.  I decided to do a fresh install of the Preview release and got no warning (there shouldn't be since it wasn't comparing to anything).  It did, however, choose a PAE kernel which has never been offered.  Not sure of the ramifications of that...
Comment 8 Chris Lumens 2009-05-03 19:15:49 EDT
There are two different ones, of course, and they are now both fixed.  The second fix did not end up being in the preview unfortunately.
Comment 9 Walter Francis 2009-05-20 23:51:23 EDT
Yep, fixed in RC.  :)  Thanks!

Note You need to log in before you can comment on or make changes to this bug.