Bug 493205 - Python GUI Crashes
Python GUI Crashes
Status: CLOSED DUPLICATE of bug 474531
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 17:55 EDT by A. Mani
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 09:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Mani 2009-03-31 17:55:09 EDT
Description of problem:

The kickstart GUI crashes after it has been started from the KdE Menu. 

Version-Release number of selected component (if applicable):
2.7.20-1.fc10
Latest update
How reproducible:


Steps to Reproduce:
1.Start kickstart in Kmenu --> System
2. start making a new file
3.
  
Actual results:


Expected results:


Additional info:
Crash Dump:

Component: system-config-kickstart
Summary: TB05ec0f49 rpm-warm-cache.py:32:postreposetup_hook:TypeError: 'NoneType' object is unsubscriptable

Traceback (most recent call last):
  File "/usr/bin/system-config-kickstart", line 90, in <module>
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 170, in __init__
    self.packages_class = packages.Packages(xml, self.ksHandler)
  File "/usr/share/system-config-kickstart/packages.py", line 234, in __init__
    self.y = sckYumBase(callback = d)
  File "/usr/share/system-config-kickstart/packages.py", line 144, in __init__
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 86, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 101, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 112, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 592, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 435, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 223, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 71, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 178, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rpm-warm-cache.py", line 32, in postreposetup_hook
    cmd = commands[0]
TypeError: 'NoneType' object is unsubscriptable

Local variables in innermost frame:
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x7f7b950aa290>
commands: None
opts: None
Comment 1 James Antill 2009-04-01 09:49:22 EDT

*** This bug has been marked as a duplicate of bug 474531 ***

Note You need to log in before you can comment on or make changes to this bug.