Bug 493213 - dhcp should obsolete libdhcp4client
dhcp should obsolete libdhcp4client
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-31 18:46 EDT by Peter Robinson
Modified: 2009-04-04 06:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 15:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-03-31 18:46:30 EDT
libdhcp4client is no longer shipped so dhcp shoudld obsolete the package to ensure its cleaned up during the upgrade process.
Comment 1 David Cantrell 2009-04-01 01:09:10 EDT
Fixed in dhcp-4.1.0-13.fc11.
Comment 2 Peter Robinson 2009-04-03 06:33:42 EDT
Just realised after testing that this won't work on a standard workstation install because the dhcp package isn't installed by default. Maybe NetworkManager or dhclient should be the ones to obsolete it.
Comment 3 David Cantrell 2009-04-03 15:48:28 EDT
$ repoquery --whatobsoletes libdhcp4client
dhclient-12:4.1.0-14.fc11.x86_64

I meant it was fixed in the dhcp package, which produces the dhclient subpackage.
Comment 4 Peter Robinson 2009-04-04 06:14:07 EDT
I figured you'd done something like that but it still doesn't seem to remove the old ones on a yum update

# rpm -qa | grep dhc| sort
dhclient-4.1.0-14.fc11.i586
dhcpv6-client-1.2.0-1.fc11.i586
libdhcp-1.99.8-1.fc10.i386
libdhcp4client-4.0.0-33.fc10.i386
libdhcp6client-1.0.22-1.fc10.i386
[root@trinity ~]# repoquery --whatobsoletes libdhcp4client
dhclient-12:4.1.0-14.fc11.i586
[root@trinity ~]# repoquery --whatobsoletes libdhcp6client
dhcpv6-client-0:1.2.0-1.fc11.i586

Note You need to log in before you can comment on or make changes to this bug.