Bug 493221 - xorg-x11-drivers should obsolete retired xorg drivers
xorg-x11-drivers should obsolete retired xorg drivers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-31 19:23 EDT by Peter Robinson
Modified: 2009-04-13 14:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 14:52:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-03-31 19:23:44 EDT
it seems that list of drivers below are obsolete for F11 (and possibly replaced by evdev) but it seems no package obsoletes them so they stick around after a yum upgrade to F11-beta. I'm guessing that as xorg-x11-drivers pseudo package pulls all the drivers in it should also be the package that obsoletes them once they are no longer relevant so that they are cleaned up between distro upgrades.

xorg-x11-drv-calcomp-1.1.2-1.fc9.i386
xorg-x11-drv-citron-2.2.1-1.fc9.i386
xorg-x11-drv-diamondtouch-0.2.0-0.1.fc9.i386
xorg-x11-drv-digitaledge-1.1.1-1.fc9.i386
xorg-x11-drv-dmc-1.1.2-1.fc9.i386
xorg-x11-drv-dynapro-1.1.2-1.fc9.i386
xorg-x11-drv-jamstudio-1.2.0-1.fc9.i386
xorg-x11-drv-magellan-1.2.0-1.fc9.i386
xorg-x11-drv-microtouch-1.2.0-1.fc9.i386
xorg-x11-drv-palmax-1.2.0-1.fc9.i386
xorg-x11-drv-spaceorb-1.1.0-6.fc9.i386
xorg-x11-drv-summa-1.2.0-2.fc10.i386
xorg-x11-drv-tek4957-1.2.0-1.fc9.i386
xorg-x11-drv-ur98-1.1.0-5.fc9.i386
xorg-x11-drv-wiimote-0.0.1-1.fc9.i386
Comment 1 Adam Jackson 2009-04-13 14:52:11 EDT
We've been doing this in xorg-x11-server instead.  -drivers is kind of an optional metapackage, whereas the server is mandatory if you want, well, an X server.

Fixed in 1.6.0-20.fc11.

Note You need to log in before you can comment on or make changes to this bug.