Bug 493230 - Tune error reporting and logging in prod logs
Tune error reporting and logging in prod logs
Status: CLOSED WONTFIX
Product: JBoss Customer Support Portal
Classification: Retired
Component: Web-General (Show other bugs)
AMS Backlog
All Linux
low Severity medium
: ---
: ---
Assigned To: Nathan Lugert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 21:30 EDT by John Sanda
Modified: 2010-08-10 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 10:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sanda 2009-03-31 21:30:55 EDT
Description of problem:
The prod logs are regularly filled with warning and error logging statements as well as a number of exceptions. All of the noise in the logs makes debugging more difficult, makes it harder to identify production problems sooner, and it makes the jobs of engineering support more diffcult. Here are some examples of the "noise":

* ERROR [org.jboss.jbossnetwork.repo.filter.UnbindFilter] Could not unbind [https://10.8.1.121:8080/slide/files/customer/14244__jboss-4.0.5.GA.zip]. Cause: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake

* ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/jbossnetwork].[rssFeed]] Servlet.service() for servlet rssFeed threw exception
churchillobjects.rss4j.generator.RssGenerationException: Each channel must have at least one item

* ERROR [com.jboss.jbossnetwork.ui.actions.JBossAction] Exception
com.jboss.jbossnetwork.software.ProductFamilyAccessException: Customer with ID 11289 does not have access to software in the product family, allProductsJboss


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The SSLHandshakeException occurs when users download content. This is coming from the slide application. It has been in the logs for a long time and does not appear to be preventing users from downloading content. The exception merits some investigation though.


The RssGenerationException is coming from the CSP when the RSS feed is requested and there is no content in the feed. It is entirely possible to request the RSS feed while having no access to any content. In that case, we probably don't need to long anything more than a warning message. 

The ProductFamilyAccessException is a recoverable exception thrown from the EJB layer that indicates either that the user has requested to view content for which she does not have access or requested content that does not exists. In the latter case, we should throw a different exception, something like ProductFamilyNotFoundException. In both cases it is sufficient to just log a warning message.
Comment 1 David Spalding 2010-06-07 14:50:46 EDT
User review session:

Does this still need to be taken up, or is this no longer a problem? Biz owner
probably never sees the logs, so this would be an issue for Production 
Control and the lead developer.
Comment 2 Nathan Lugert 2010-06-07 15:34:21 EDT
I know the SSLHandshakeException no longer happens since we no longer use Slide, but the other two might still be happening. I'm also not sure how often these errors get logged in production, but probably not too often.

Note You need to log in before you can comment on or make changes to this bug.