Bug 493234 - (r3dskull) Install Wizard doesn't start
Install Wizard doesn't start
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: zabbix (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 22:44 EDT by Hiran Arias
Modified: 2009-06-15 21:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.6.4-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:51:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiran Arias 2009-03-31 22:44:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install zabbix-server zabbix-web
2.Open zabbix URL
  
Actual results:
Only get a Error page Installation Wizard doesn't start

Expected results:
It should open installation wizard at first access.

Additional info:
Configuration File /etc/zabbix/zabbix.conf.php shouldn't exist so the installation wizard can be started.

Delete the file and you get the Installation Wizard.
Comment 1 Dan Horák 2009-04-01 05:13:14 EDT
Hm, they changed the logic when to show the setup/installation wizard. Previously it was started when the frontend couldn't connect to the database and now the config file must not exist.

Jeff, I have few things that could be done in the package:
- no need to move db.inc.php to /etc/zabbix, it is not changed during the setup in 1.6 (and probably in 1.4 too)
- create a dir /etc/zabbix/web with apache:apache ownership
- patch frontend/include/config.php.inc to define ZBX_CONFIGURATION_FILE as /etc/zabbix/web/zabbix.conf.php
- mark /etc/zabbix/web/zabbix.conf.php as %ghost + %config in the %files section
Comment 2 Ville Skyttä 2009-04-07 12:41:48 EDT
FWIW, that plan sounds good to me.
Comment 3 Ville Skyttä 2009-04-07 12:47:28 EDT
...but if zabbix.conf.php is moved, please remember to take care of existing setups on upgrades by copying/moving files around.

Also, what modes did you think of for the /etc/zabbix/web dir and the file(s) in it?  zabbix.conf.php shouldn't be world readable due to db passwords in it.

One alternative would be to leave the config file as /etc/zabbix/zabbix.conf.php and change perms to e.g. 0640 root:apache.  That'd need some scriptlet actions for upgrades too though, see bug 494434.
Comment 4 Fedora Update System 2009-05-18 09:30:13 EDT
zabbix-1.6.4-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/zabbix-1.6.4-3.fc10
Comment 5 Fedora Update System 2009-05-18 22:11:47 EDT
zabbix-1.6.4-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update zabbix'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5141
Comment 6 Fedora Update System 2009-06-15 21:51:27 EDT
zabbix-1.6.4-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.