Bug 493245 - Failed to read saved session file warning on new sessions.
Summary: Failed to read saved session file warning on new sessions.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-01 04:50 UTC by Tomislav Vujec
Modified: 2009-12-27 20:27 UTC (History)
1 user (show)

Fixed In Version: 2.28.0-13.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-27 20:27:12 UTC


Attachments (Terms of Use)
Proposed patch to remove the warning. (492 bytes, patch)
2009-04-01 04:50 UTC, Tomislav Vujec
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 577576 None None None Never

Description Tomislav Vujec 2009-04-01 04:50:13 UTC
Created attachment 337438 [details]
Proposed patch to remove the warning.

Description of problem:
When started without session related command line parameters (e.g. from
gnome-session), metacity picks up client_id from the DESKTOP_AUTOSTART_ID
environment variable. Unfortunately, there is no way to distinguish if this was
passed from a config file, representing old saved session, or generated by
gnome-session, therefore load_state is attempted in each case. If the client_id
is generated, there will be no session file, and metacity will report a
warning. Since use case of starting new fresh session is much more common than
loading existing saved session, most users will find a warning in their session
log file (e.g. .xsession-errors), which can be fairly confusing. Warning should
be either removed or changed to a debug message. Alternatively, there should be
a method to distinguish between generated and restored IDs, but that might
require changes to the autostart specs.

Version-Release number of selected component (if applicable):
2.26.0-1

How reproducible:
Log into gnome desktop without any saved sessions.

Actual results:
metacity reports warning:
Window manager warning: Failed to read saved session file <HOME>/.config/metacity/sessions/<ID>.ms: Failed to open file '<HOME>/.config/metacity/se
ssions/<ID>.ms': No such file or directory

Expected results:
No warning.

Comment 1 Bug Zapper 2009-06-09 12:54:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Fedora Update System 2009-12-10 23:53:07 UTC
metacity-2.28.0-12.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/metacity-2.28.0-12.fc12

Comment 3 Fedora Update System 2009-12-11 18:22:18 UTC
metacity-2.28.0-12.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update metacity'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13084

Comment 4 Fedora Update System 2009-12-22 04:38:08 UTC
metacity-2.28.0-13.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update metacity'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13084

Comment 5 Fedora Update System 2009-12-27 20:26:40 UTC
metacity-2.28.0-13.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.