Bug 493258 - "Disk is already in use by another guest!"
"Disk is already in use by another guest!"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 02:21 EDT by Jens Petersen
Modified: 2009-04-03 23:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 23:50:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-04-01 02:21:56 EDT
Description of problem:
When trying to reinstall a deleted guest, virt-manager gives the above dialog message.

Version-Release number of selected component (if applicable):
0.6.1

Steps to Reproduce:
1. network install rawhide (backtrace)
2. delete failed rawhide guest
3. reinstall using same disk filename
  
Actual results:
Dialog saying:
`Disk "/var/lib/libvirt/images/rawhide.img" is already in use by another guest!

Do you really want to use the disk?  [Yes] [No]'
"""

Expected results:
Dialog should say `Disk "/var/lib/libvirt/images/rawhide.img" is already exists!'

Additional info:
It should only say "already in use by another guest" if the image is really owned by one of the current guests.
Comment 1 Mark McLoughlin 2009-04-03 06:43:51 EDT
Hmm, I can't reproduce. Could you try and narrow it down to easier reproduce instructions? Also, please include virt-manager.log. Thanks
Comment 2 Jens Petersen 2009-04-03 23:50:37 EDT
Sorry I think this is my bad - I think I thought I had deleted the guest but I guess I hadn't.  Closing this out - if there is anything more I can reopen.

Note You need to log in before you can comment on or make changes to this bug.