Bug 49329 - configure script incorrectly checks for GNU gettext with --disable-nls flag
Summary: configure script incorrectly checks for GNU gettext with --disable-nls flag
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: popt (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-18 02:03 UTC by Ben Zeckel
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 02:03:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Zeckel 2001-07-18 02:03:40 UTC
Description of Problem:

In the libpopt1.6.2 configure script, there is a check for gettext which 
seems
a little broken with --disable-nls

gettext isn't needed for building with this option as far as I can tell
- using this option and removing the following gettext check results in
binaries that appear to work so far. Since I haven't installed a ARM binary
version of gettext on my development system and the ARM binaries seem to 
work
fine (pump for example) on my test board, I assume that gettext is neither
linked against nor included in the binary.

Here is the section in question:

if test ! -f ../rpm.c
then
  echo $ac_n "checking for GNU xgettext""... $ac_c" 1>&6
echo "configure:2286: checking for GNU xgettext" >&5
  xgettext --version 2>&1 | grep 'GNU gettext' >/dev/null 2>&1 || { 
echo "configure: error:
  *** GNU gettext is required. The latest version
  *** is always available from ftp://ftp.gnu.org/gnu/gettext/." 1>&2; exit 
1; }
  echo "$ac_t""yes" 1>&6
fi


There should probably be a check for a --disable-nls option or something
here - I would supply a patch, but I don't know how to use autoconf yet.

How reproducable:

every time

Steps to Reproduce:

get 1.6.2 from ftp.rpm.org (or cvs.rpm.org latest version)
on a machine without GNU gettext installed, run ./configure
with --disable-nls option
configure fails.
edit out above check and repeat configure command
make
build works despite lack of GNU gettext

Actual Results:

--disable-nls without gettext fails during configure script

Expected Results:

configure script should allow build to continue without gettext if
--disable-nls is used


Additional Information:
	
build will correctly fail if the check is removed and --disable-nls
is not used. The check is only made if ../rpm.c does not exist. Since
popt is probably usually build along with rpm, this does not show up
most of the time.

Comment 1 Jeff Johnson 2001-07-24 03:10:58 UTC
This check was added at the request of the GNOME project, as it
minimizes a support issue for them.


Note You need to log in before you can comment on or make changes to this bug.