Bug 493294 - System recovery partition offered as "Other" boot option (F11beta)
System recovery partition offered as "Other" boot option (F11beta)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 06:13 EDT by Jurgen Kramer
Modified: 2009-04-28 13:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 13:41:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2009-04-01 06:13:12 EDT
Description of problem:
With F11beta install anaconda offered to add the System recovery partition as "Other" boot option for GRUB.

Version-Release number of selected component (if applicable):
anaconda from F11 beta release

How reproducible:
always

Steps to Reproduce:
1. Start F11 beta install from i386 DVD
2.
3.
  
Actual results:
Anaconda offered the first partition as "Other" OS boot option while this is the system recovery partition (type 12).

Expected results:
Anaconda does not offer a/the System recovery partition as valid "Other" OS option

Additional info:
The partition layout is as follows:
Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7881e424

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         784     6297448+  12  Compaq diagnostics
/dev/sda2             785        5788    40194630    7  HPFS/NTFS
/dev/sda3   *        5789       10250    35841015   af  Unknown
/dev/sda4           10251       19457    73955227+   5  Extended
/dev/sda5           10251       10276      208813+  83  Linux
/dev/sda6           10277       10537     2096451   82  Linux swap / Solaris
/dev/sda7           10538       19457    71649868+  83  Linux
Comment 1 Chris Lumens 2009-04-08 15:41:52 EDT
There's not really any good way to filter these diagnostics partitions out in the new storage code.  They're a bootable partition with a dos filesystem, which makes them look just like a Windows or similar OS is installed there.  Additionally, the partition ID isn't really accessible anymore since it's a msdos disklabel specific feature that the new pyparted and booty doesn't want to expose.  Is having it in the bootloader causing real annoyance?
Comment 2 Jurgen Kramer 2009-04-15 13:57:46 EDT
Not for me, I know that I need to modify grub and how to do it. But some people won't probably like it if they accidentally start a system recovery instead of booting into XP.
Comment 3 Chris Lumens 2009-04-28 13:41:49 EDT
Unfortunately there's not really anything we can do about this for F11.  There's a possible fix, but it's very complicated and prone to causing more errors that we won't have time to fix before the final release.

Note You need to log in before you can comment on or make changes to this bug.