Bug 49330 - HP_TIMING_AVAIL and librt
HP_TIMING_AVAIL and librt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-17 23:41 EDT by hjl
Modified: 2016-11-24 09:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 15:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hjl 2001-07-17 23:41:23 EDT
librt is compiled with

#if HP_TIMING_AVAIL
...
#endif

But it is only defined for i686. Shouldn't there
be an i686 version of librt. It is compiled in the
glibc build. We just need to include it in the i686
glibc rpm.
Comment 1 Glen Foster 2001-07-18 15:59:27 EDT
This defect should be fixed before next release.
Comment 2 Jakub Jelinek 2001-07-18 16:15:31 EDT
It should not, because it is not a bug.
All libraries/binaries in glibc*.i686.rpm are i686 versions.
The difference between /lib/i686/ and /lib libraries is that /lib/i686/
libraries were built with --enable-kernel=2.4.1 while /lib libraries were
built with --enable-kernel=2.2.5. HP_TIMING_AVAIL AFAIK does not care which
minimal version the library supports. The only thing which cares is I believe
%gs based threads, for the rest it is just an optimization and that
optimization is only useful where it matters a lot (libc).
I should actually check if it matters to libm at all, probably not, so it
should maybe go away from /lib/i686.
I think librt does not syscalls and have no idea where else would it matter.

Note You need to log in before you can comment on or make changes to this bug.