Bug 493322 - problems with QA radeon rotate test
problems with QA radeon rotate test
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 08:35 EDT by Peter F. Patel-Schneider
Modified: 2009-05-18 19:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 19:42:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg after rotate and relogin (50.88 KB, text/plain)
2009-04-01 08:35 EDT, Peter F. Patel-Schneider
no flags Details
lspci after rotate and relogin (1.89 KB, text/plain)
2009-04-01 08:36 EDT, Peter F. Patel-Schneider
no flags Details
Xorg.log after rotate and relogin (115.41 KB, text/plain)
2009-04-01 08:37 EDT, Peter F. Patel-Schneider
no flags Details
xranr --verbose after rotate and relogin (10.74 KB, text/plain)
2009-04-01 08:38 EDT, Peter F. Patel-Schneider
no flags Details

  None (edit)
Description Peter F. Patel-Schneider 2009-04-01 08:35:42 EDT
Created attachment 337502 [details]
dmesg after rotate and relogin

Description of problem: problem with radeon rotate test


Version-Release number of selected component (if applicable): QA 20090401 live 


Reboot with two monitors is weird, if not in clone mode
- two monitors 
  - laptop 1600x1200 LCD
  - external DELL Trinitron 20" CRT capable of 1600x1200 resolution, 
    connected to docking station VGA connector
- splash screen OK
- graphical boot sequence OK, except not at 1600x1200 resolution
  - CRT in full screen
  - LCD has black on bottom and RHS
  - resolution probably 1280x1024 or so
  - both monitors flicker about 40% through boot sequence
  - CRT does a reset just before login screen
    - then resolution on both monitors at 1600x1200
    - it looks as if the CRT is running at 60Hz, not the better 85Hz 
  - CRT flashes back to graphical boot screen at reduced size
  - then LCD goes to black, but cursor can move into it
  - CRT shows login screen
- logging in and switching to clone mode fixes everything up
  - CRT appears to go to 

Reboot after going to clone mode 
- everything is the same as above until the login screen shows up 
- then login screen mirrored on both monitors
  - but CRT at 60Hz or so
- at automatic login, both monitors show boot screen momentarily
- then both show desktop, but CRT is at higher refresh rate

Here is xrandr output 

[liveuser@localhost ~]$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 8192 x 8192
VGA-0 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 388mm x 291mm
   2048x1536      60.0  
   1920x1440      60.0  
   1856x1392      60.0  
   1792x1344      75.0     60.0  
   1600x1200      85.0*    75.0     70.0     65.0     60.0  
   1400x1050      74.8     60.0  
   1280x1024      85.0     75.0     60.0  
   1280x960       85.0     60.0  
   1152x864       75.0  
   1024x768       85.0     75.1     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     75.0     72.8     75.0     60.0     59.9  
   720x400        85.0     70.1  
   640x400        85.1  
   640x350        85.1  
   0x0             0.0  
LVDS connected 1600x1200+0+0 (normal left inverted right x axis y axis) 304mm x 228mm
   1600x1200      60.0*+   50.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  
   0x0             0.0  
DVI-0 disconnected (normal left inverted right x axis y axis)

QUESTION:  Why does the LCD not show 1400x1050, 1280x1024, etc.?

gnome-display-properties appears to be somewhat broken
- rotating left does rotate left 
  - with many glitches 
    - probably due to incorrect notions of display size
- rotating upside down works
- after a few seconds goes back to unrotated login screen

here is data after booting in clone mode, rotating left, and then having a forced login

Output of lspci, dmesg, Xorg.log and 'xrandr --verbose' attached
Comment 1 Peter F. Patel-Schneider 2009-04-01 08:36:36 EDT
Created attachment 337503 [details]
lspci after rotate and relogin
Comment 2 Peter F. Patel-Schneider 2009-04-01 08:37:55 EDT
Created attachment 337504 [details]
Xorg.log after rotate and relogin
Comment 3 Peter F. Patel-Schneider 2009-04-01 08:38:33 EDT
Created attachment 337505 [details]
xranr --verbose after rotate and relogin
Comment 4 Peter F. Patel-Schneider 2009-05-18 19:42:39 EDT
Fixed for quite a while in rawhide, so I'm closing my report.

Note You need to log in before you can comment on or make changes to this bug.