Bug 493340 - condor_configure_node does not prompt for HA Schedd name
condor_configure_node does not prompt for HA Schedd name
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
low Severity medium
: 1.2
: ---
Assigned To: Robert Rati
Martin Kudlej
:
Depends On:
Blocks: 527551
  Show dependency treegraph
 
Reported: 2009-04-01 09:58 EDT by Robert Rati
Modified: 2009-12-03 04:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Grid bug fix C: The condor_configure_node tool continues without the name of the ha-schedd being specified C: The user will not know what the name of he ha-schedd is to be able to configure the other nodes in the pool. F: The condor_configure_node tool was changed, so that it prompts for the name of the ha-schedd R: The condor_configure_node tool can not be run without a name for the ha-schedd The condor_configure_node tool continues without the name of the ha-schedd being specified. This could cause the user problems when configuring the other nodes in the pool. The tool was changed, and it now prompts for the name of the ha-schedd.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 04:16:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2009-04-01 09:58:40 EDT
Description of problem:
The condor_configure_node tool does not prompt for the name of the ha-shedd, so because the SCHEDD_NAME is hard coded to ha-schedd@ the user will need to know this when configuring all other nodes.  The tool should prompt the user for the name for the HA scheduler setup.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2009-09-17 16:16:15 EDT
HA schedulers will now be prompted for.  Fixed in:
condor-remote-configuration-1.0-17  

All HA schedulers will need to be re-configured with this package for the changes
to take affect.
Comment 3 Martin Kudlej 2009-10-22 09:20:58 EDT
I've tried it on condor-remote-configuration-server-1.0-14 on RHEL5.4 and condor-remote-configuration-1.0-14 on RHEL4.8 (i386 x x86_64) and there isn't any SCHEDD_NAME in pool settings (condor_configure_node).
I've tried it on condor-remote-configuration(-server)-1.0-22 and the setting is there and it could be configured --> VERIFIED
Comment 4 Irina Boverman 2009-10-29 10:29:45 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
please see bug summary.
Comment 5 Lana Brindley 2009-11-04 21:47:48 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,8 @@
-please see bug summary.+Grid bug fix
+
+C: The condor_configure_node tool continues without the name of the ha-schedd being specified
+C: The user will not know what the name of he ha-schedd is to be able to configure the other nodes in the pool.
+F: The condor_configure_node tool was changed, so that it prompts for the name of the ha-schedd
+R: The condor_configure_node tool can not be run without a name for the ha-schedd 
+
+The condor_configure_node tool continues without the name of the ha-schedd being specified. This could cause the user problems when configuring the other nodes in the pool. The tool was changed, and it now prompts for the name of the ha-schedd.
Comment 6 errata-xmlrpc 2009-12-03 04:16:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1633.html

Note You need to log in before you can comment on or make changes to this bug.