Bug 493343 - systray icon not showing up after incorrect broken battery warning
systray icon not showing up after incorrect broken battery warning
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 10:01 EDT by Michel Alexandre Salim
Modified: 2009-04-01 10:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:27:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2009-04-01 10:01:49 EDT
Description of problem:
g-p-m would incorrectly claim that the laptop's battery is broken, and fails to display the notification icon after that. Other functionalities (e.g. brightness keys) still work, but suspend/resume is no longer possible, either through the Main Menu or through the g-p-m systray icon (since it is not displayed, it cannot be right-clicked)

Going to try booting the -16 kernel revision and see if the problem was already present there; AFAIR it worked just fine yesterday.

Version-Release number of selected component (if applicable):
kernel-2.6.29-21.fc11.x86_64
gnome-power-manager-2.26.0-1.fc11.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Unplug AC adapter
2. killall gnome-power-manager && gnome-power-manager (tried with --verbose --no-daemon too; no difference)
3. Repeat with AC adapter plugged
  
Actual results:
The following pop-up notice is given in both (2) and (3):
"""
Battery may be broken

Your battery has a very low capacity 69%), which means that it may be old or broken.
"""
After that, the notification icon is not shown.

Expected results:
Should work as usual, regardless of whether g-p-m detects a broken battery or not

Additional info:
[michel@erdos BAT0]$ cat /proc/acpi/battery/BAT0/info 
present:                 yes
design capacity:         5200 mAh
last full capacity:      4798 mAh
battery technology:      rechargeable
design voltage:          11100 mV
design capacity warning: 520 mAh
design capacity low:     157 mAh
capacity granularity 1:  52 mAh
capacity granularity 2:  52 mAh
model number:            DELL WR0478
serial number:           15776
battery type:            LION
OEM info:                Samsung SDI
[michel@erdos BAT0]$ cat /proc/acpi/battery/BAT0/state
present:                 yes
capacity state:          ok
charging state:          charging
present rate:            997 mA
remaining capacity:      4500 mAh
present voltage:         12537 mV
Comment 1 Michel Alexandre Salim 2009-04-01 10:14:55 EDT
Tried DeviceKit-power 006-3, 007-2 and 008-0.1.20090401git; the same problem occurs with all of them.

So there are two separate problems:
1. The battery is incorrectly reported as broken (/proc/acpi/battery indicates a working battery, and the charging level is definitely > 69 %)
2. If a battery is broken, g-p-m does not have an icon for it so if the user missed the initial warning, they would not be aware of the problem
Comment 2 Michel Alexandre Salim 2009-04-01 10:27:37 EDT
False alarm; the 008 git snapshot works, but only after restarting the computer.

Note You need to log in before you can comment on or make changes to this bug.