Bug 49336 - PIPESTATUS vari able not set
Summary: PIPESTATUS vari able not set
Status: CLOSED DUPLICATE of bug 49335
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bash   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-18 05:54 UTC by j. alan eldridge
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 05:55:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description j. alan eldridge 2001-07-18 05:54:30 UTC
Description of Problem:

       PIPESTATUS
              An  array  variable (see Arrays below) containing a
              list of exit status values from  the  processes  in
              the   most-recently-executed   foreground  pipeline
              (which may contain only a single command).


How Reproducible:

[alane@wwweasel alane]$ false
[alane@wwweasel alane]$ echo $?
1
[alane@wwweasel alane]$ false|false
[alane@wwweasel alane]$ echo ${#PIPESTATUS[*]}
1
[alane@wwweasel alane]$ false|false
[alane@wwweasel alane]$ echo $PIPESTATUS
0
[alane@wwweasel alane]$ rpm -q bash
bash-2.05-8
[alane@wwweasel alane]$ set | grep BASH
BASH=/bin/bash
BASH_ENV=/home/alane/.bashrc
BASH_VERSINFO=([0]="2" [1]="05" [2]="8" [3]="1" [4]="release" 
[5]="i386-redhat-linux-gnu")
BASH_VERSION=$'2.05.8(1)-release'
[alane@wwweasel alane]$


Does this have to enabled by an option to configure when bash is built?

Additional Notes:

I would be very surprised if this problem does not exist in the release 
RPMS of bash as well, unless something obvious has changed very recently.

Comment 1 Bernhard Rosenkraenzer 2001-07-18 10:17:58 UTC

*** This bug has been marked as a duplicate of 49335 ***


Note You need to log in before you can comment on or make changes to this bug.