This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493360 - choose to replace existing linux system...
choose to replace existing linux system...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 10:52 EDT by Jóhann B. Guðmundsson
Modified: 2010-02-11 15:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 12:13:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-04-01 10:52:58 EDT
Description of problem:

Just tested if anaconda was intellect enough to choose to wipe only on of my installation ( first one ) on the HD when choose to replace existing linux system

I was hoping that it would look for /boot partition and if more then one /boot was found offer the end user to choose which one to use then look for the first / partition and of more then one was found ask the end user which one to choose 
same goes for swap etc but leave the partition out that did not fit into our optional partition schema for example if an end user has more then one installation and has a single partition called "Share" and is sharing that partition between multiple installations.. 

I expected it to wipe all linux partition it found and let's just say it lived up to my expectation as in not being smart enought.

Now what I did not expect from this was it also used the remaining free space on the HD which in my case equalled to wiping the whole drive.  

Now this leaves me wondering as well if there was another os ( other than linux ) it would have wiped that one as well ( unless it's checking for ntfs filesystem along with what ever bsd an solaris use as their default and does not touch those )

Version-Release number of selected component (if applicable):

Beta

How reproducible:

Well once 

Steps to Reproduce:
1. Have multiple linux installations can be different distros
2. choose to replace existing linux system
3. Next next done
  
Actual results:

Wiping all linux partition and using the remaining free space.

Expected results:

well at least leave the remaining free space alone guess 
the other thing would be expecting to much..

Additional info:
Comment 1 Jóhann B. Guðmundsson 2009-04-01 10:55:35 EDT
I was using the DVD and as such expected it to offer all the *DE we have to offer
and in the spirit of equalness we should offer all of them or none..
Comment 2 Jóhann B. Guðmundsson 2009-04-01 11:51:40 EDT
Crap the above comment was meant for #493302 

Penalty to be working on multiple reports at the same time..
Comment 3 David Lehman 2009-04-01 12:13:07 EDT
This option does not make an effort to identify individual installations -- it simply removes partitions of a type that can be reasonably expected to be part of a linux installation (ext2, ext3, swap, lvm pv, &c). It does not remove NTFS since NTFS is by no accounts a linux filesystem.

As far as the use of free space, why not use the free space? Other users would file a bug saying we are wasting their HD by not using all free space. If you have very specific expectations you should be partitioning manually, either using kickstart or the GUI.
Comment 4 Jóhann B. Guðmundsson 2009-04-01 12:30:47 EDT
Perhaps a warning is in order that A) warns the end user that this will 
remove all linux partitions on the HD and B) it will also merge/use all the free disk space at the same time. 

Regarding creating a "custom layout" let's hope it will be in usable state in F11 and before Final.
Comment 5 matthew 2010-02-09 07:52:17 EST
I could not belive my eyes when I saw all my HDD messed up, the installer tells me it replaces the existing Linux system, it does not state it wipes all HDD except for NTFS. Now I have to recover all my partition and files, I don't know if there's something to be done left. This issue needs urgent attention!
Comment 6 Chris Lumens 2010-02-09 09:36:42 EST
Please see the new text for that screen:

https://fedoraproject.org/wiki/Design/AnacondaStorageUI#Choose_Partitioning_Scheme
Comment 7 matthew 2010-02-09 10:27:36 EST
Yes, It is also my fault for not being extra careful, but that statement is not really clear "(partitions crated from a previous linux installation)", because I assume it removes partitions used by that installation. I actually created those partitions long before I installed Linux one one of them. So, it's easy to assume the installer checks what partitions that linux installation needs for it to function (such as the root partition and the swap one), not just any ext2/3/4 partition.
Comment 8 matthew 2010-02-09 10:31:58 EST
PS: Nor does it state it removes ALL Linux partitions. I mean, I would not have belived a non alpha installer could just be so dangerous.
Comment 9 David Lehman 2010-02-09 12:28:54 EST
(In reply to comment #8)
> PS: Nor does it state it removes ALL Linux partitions. I mean, I would not have
> belived a non alpha installer could just be so dangerous.    

You are installing an operating system. You should have read the installation guide, the release notes, &c before starting to click your way through the installer. We have improved the text for the automatic partitioning screen, as you have seen. There really isn't anything more to be done here.
Comment 10 David Lehman 2010-02-11 15:46:41 EST
We have clarified the text further to avoid issues like this in the future:

Old first sentence: "Removes only Linux partitions (created from a previous Linux installation)."

New first sentence: "Removes all Linux partitions on the selected device(s)."

Note You need to log in before you can comment on or make changes to this bug.