Bug 493389 - smoltSendProfile fails: Could not contact server: Invalid token
smoltSendProfile fails: Could not contact server: Invalid token
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 12:11 EDT by John Reiser
Modified: 2009-06-22 16:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 16:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-01 12:11:26 EDT
Description of problem: python traceback when invoking smoltSendProfile


Version-Release number of selected component (if applicable):
smolt-1.2-4.1.fc11.noarch


How reproducible: Haven't tried.


Steps to Reproduce:
1. Install Fedora 11 alpha, decline to send smolt profile during firstboot. "yum update" to just before beta.
2. Follow directions for participating in Radeon test day: invoke smoltSendProfile without superuser privileges.
3. Try again with superuser privileges.
  
Actual results: First time (not superuser): 
	Your pub_uuid file  could not be cached: [Errno 13] Permission denied: '/etc/sysconfig/pub-uuid-www.smolts.org'
	Maybe re-run as root?
second time (as superuser):
Server Message: "Critical [20]: Invalid Token"
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 176, in <module>
    timeout=opts.timeout)
  File "/usr/share/smolt/client/smolt.py", line 505, in send
    pub_uuid = serverMessage(o.read())
  File "/usr/share/smolt/client/smolt.py", line 309, in serverMessage
    raise ServerError, _('Could not contact server: %s') % line.split('ServerMessage: ')[1]
smolt.ServerError: 'Could not contact server: Critical [20]: Invalid Token'

Expected results: successful operation with no complaints


Additional info: I edited the Radeon test day wiki page to show that smoltSendProfile might require superuser privileges.  The contents of /etc/sysconfig/hw-uuid did not match the uuid displayed by the first smoltSendProfile, perhaps because I added a network interface card after installing F11-alpha but before Radeon test day.  All in all, not a good day for smolt package.
Comment 1 Bug Zapper 2009-06-09 08:58:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Mike McGrath 2009-06-22 16:10:29 EDT
The invalid token error is actually a timeout thing I've been fighting with.  I'm working on different ways to fix it, I've made incremental fixes to it.  But we'll continue to get them when the db is locked during a backup, or re-indexing.

I've put a better error message in, as well as added more smolt server instances.

Note You need to log in before you can comment on or make changes to this bug.