Bug 493413 - Looking for Manufacturer/ProductName/Serial Number to be reported by dmidecode within KVM instance
Looking for Manufacturer/ProductName/Serial Number to be reported by dmidecod...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity low
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 12:56 EDT by Andrew_Blatt
Modified: 2010-10-23 04:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 10:47:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew_Blatt 2009-04-01 12:56:56 EDT
Description of problem:
dmidecode shows "Not Specified" for System Information (Manufacturer/Product Name/Serial Number).

Version-Release number of selected component (if applicable):
#rpm -q -a |grep kvm
kvm-83-9.el5ovirt
etherboot-zroms-kvm-5.4.4-8.el5ovirt
kmod-kvm-83-9.el5ovirt
kvm-qemu-img-83-9.el5ovirt


How reproducible:
Built a KVM with RH 5.3 and ran dmidecode.

Steps to Reproduce:
1. create kvm instance
2. install RH 5.3
3. ran dmidecode
  
Actual results:
[root@elabvhost124 ~]# dmidecode -s system-manufacturer
Not Specified
[root@elabvhost124 ~]# dmidecode -s system-product-name
Not Specified
[root@elabvhost124 ~]# dmidecode -s system-serial-number
Not Specified


Expected results:


Additional info:
Comment 1 Chris Van Hoof 2009-06-11 14:22:45 EDT
Hi Andrew -- It looks like this was changed in later releases (through another bug):

"""
dmidecode -s system-manufacturer
Red Hat
dmidecode -s system-product-name
Red Hat Enterprise Virtualization Hypervisor
dmidecode -s system-serial-number
34343831-3833-5553-4538-32304E363952 
"""
Comment 2 Karl Hastings 2009-07-09 11:00:12 EDT
/usr/libexec/qemu-kvm --help
...
-smbios file=binary
                Load SMBIOS entry from binary file
-smbios type=0[,vendor=str][,version=str][,date=str][,release=%d.%d]
                Specify SMBIOS type 0 fields
-smbios type=1[,manufacturer=str][,product=str][,version=str][,serial=str]
              [,uuid=uuid][,sku=str][,family=str]
...

The results from C#1 were generated using a commandline similar to:
/usr/libexec/qemu-kvm -smbios
type=1,manufacturer="Red Hat",product="Red Hat Enterprise Virtualization
Hypervisor",serial=34343831-3833-5553-4538-32304E363952
Comment 4 Dor Laor 2009-11-10 10:47:20 EST
Updating status and changing to the correct component

Note You need to log in before you can comment on or make changes to this bug.