Bug 49342 - htdig crasches while refreshing database
htdig crasches while refreshing database
Product: Red Hat Linux
Classification: Retired
Component: htdig (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
Our internal webserver
Depends On:
  Show dependency treegraph
Reported: 2001-07-18 09:30 EDT by ola
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-25 10:49:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description ola 2001-07-18 09:30:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
htdig crashes with the following messages while rebuilding the database.

Same error both in RH 7.1-version and Rawhide.

FATAL ERROR:Compressor::get_vals invalid comptype
FATAL ERROR at file:WordBitCompress.cc line:827 !!!

How reproducible:

Steps to Reproduce:
1. htdig
2. Wait
3. htdig

Actual Results:  FATAL ERROR:Compressor::get_vals invalid comptype
FATAL ERROR at file:WordBitCompress.cc line:827 !!!

Expected Results:  A refresh of the database.

Additional info:
Comment 1 ola 2001-07-18 10:05:21 EDT
The minimum run that crashes it:

[root@w01 /root]# htdig -v -v
ht://dig Start Time: Wed Jul 18 16:06:56 2001
New server: w01.osys.se, 80
 - Persistent connections: enabled
 - HEAD before GET: disabled
 - Timeout: 30
 - Connection space: 0
 - Max Documents: -1
 - TCP retries: 1
 - TCP wait time: 5
Trying to retrieve robots.txt file
pick: w01.osys.se, # servers = 1
0:161706:4:http://w01.osys.se/manual/content-negotiation.html:  (changed)
title: Apache Content Negotiation
url rejected: (level 1)http://w01.osys.se/manual/mod/mod_negotiation.html
url rejected: (level 1)http://w01.osys.se/manual/mod/mod_mime.html
url rejected: (level 1)http://w01.osys.se/manual/mod/mod_mime.html
url rejected: (level 1)http://w01.osys.se/manual/
 size = 22663
1:161748:3:http://w01.osys.se/Archives/Software/Sun/?D=A:  (changed)
title: Index of /Archives/Software/Sun
url rejected: (level 1)http://w01.osys.se/Archives/Software/
url rejected: (level 1)http://w01.osys.se/Archives/Software/Sun/108303-03.tar.Z
url rejected: (level 
*FATAL ERROR:Compressor::get_vals invalid comptype
FATAL ERROR at file:WordBitCompress.cc line:827 !!!
Segmentation fault
Comment 2 ola 2001-07-18 10:07:07 EDT
The contents of the directory:

[root@w01 /root]# ll /Archives/Software/Sun/
total 357160
drwxrwxr-x    2 root     archive      4096 May 27 20:38 ./
drwxrwxr-x   48 root     archive      4096 Jul 18 15:58 ../
-rw-rw-r--    1 ola      ola       1330793 Feb 28  2000 108303-03.tar.Z
-r--r--r--    1 ola      ola      55787520 Dec 31  2000 
-rw-rw-r--    1 root     archive  22485129 Jan 29  2000 
-rw-rw-r--    1 ola      ola        799676 Feb 28  2000 libforms.so.0.88
-rw-rw-r--    1 ola      ola        962560 Feb 28  2000 mtv-
-rwxr-xr-x    1 ola      ola      97621364 May 26 22:09 
-rwxr-x--x    1 ola      ola      97869654 May 27 20:38 
-rwxr-x--x    1 ola      ola      16327461 May 26 23:39 
-rwxrwxr-x    1 root     archive  68169700 Jan  5  2000 
-rw-rw-r--    1 ola      ola       3528529 Feb 28  2000 Sunray admguide.pdf
-rw-rw-r--    1 ola      ola        212669 Feb 28  2000 Sunray Product 
-rw-rw-r--    1 ola      ola        197230 Feb 28  2000 Sunray quickref.pdf
Comment 3 Phil Knirsch 2001-07-20 12:57:51 EDT
I am not able to reproduce this bug. I have tried it with various setups and
files, but it always worked...

Have you tried to delete the original htdig database first:

  rm /var/lib/htdig/*

and then ran the htdig command again twice? Maybe there was/is some strange
leftover from an old version.

Otherwise i would really need a reproducible setup as i can't track down bug
without it...

Read ya, Phil
Comment 4 Jason Tibbitts 2001-08-27 12:58:15 EDT
I'm managed to get the same error just trying to build the KDE help search
database, but it is not reproducible.  I'm running stock 7.1 with current
updates.  The rebuild progress indicator went to 67% and then just went away;
the following was logged to .xsession-errors:

[lots of the following two]
WordType::WordType: reading bad words from
/usr/share/apps/khelpcenter/en/bad_words found an, ignored because TOOSHORT
WordType::WordType: reading bad words from
/usr/share/apps/khelpcenter/en/bad_words found of, ignored because TOOSHORT
FATAL ERROR:Compressor::get_vals invalid comptype
FATAL ERROR at file:WordBitCompress.cc line:827 !!!

It failed this way several times, but now it doesn't.  I still don't get a
useful index, but that's probably a topic for another bug report.

rpm -q htdig gives:
Comment 5 ola 2001-08-27 14:03:04 EDT
Yes, I've tried deleting all of the htdig database. Same result.
Also, a similar error is reported in the bug database on the htdig homepage
(without any workaround or comments last time I checked).
Comment 6 Need Real Name 2001-11-12 11:30:49 EST
From my /etc/htdig.conf:

# SIMOS: The following has to be false, otherwise htdig coredumps badly.
wordlist_compress: false

Source: htdig mailling lists. I do not have handy a complete reference.
Comment 7 Phil Knirsch 2002-01-25 10:49:50 EST
I've updated htdig to the latest snapshop from CVS in rawhide. If you could give
that version (3.2.0-2.011302) a try and report if the problem is gone i'd
greately appreciate it.


Read ya, Phil
Comment 8 Phil Knirsch 2002-02-25 07:53:28 EST
No response in 1 month, closing now as RAWHIDE as it works for me now.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.