Bug 493453 - Upgraded F10 system to F11B, XFCE defaults to typical flashing white splash rather than no splash
Upgraded F10 system to F11B, XFCE defaults to typical flashing white splash r...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 15:54 EDT by Walter Francis
Modified: 2009-05-10 01:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-10 01:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of default XFCE configuration in F10, upgraded to F11's XFCE (89.88 KB, image/jpeg)
2009-05-02 17:14 EDT, Walter Francis
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 5067 None None None Never

  None (edit)
Description Walter Francis 2009-04-01 15:54:02 EDT
Description of problem:

According to Nirik on IRC, XFCE should default to no splash on F11, however when logging into XFCE on a clean, brand new user under an F11B desktop upgraded from F10 (32 bit) the flashing white splash is still shown.  If looking in XFCE Session's preferences, None is shown as the Splash screen.

If I change the splash from None to something else, then back to None, it indeed shows no splash.

This does not appear to happen on a fresh F11 installation.

Version-Release number of selected component (if applicable):
xfce4-session-4.5.99.1-1.fc10.i386

How reproducible:
Only tried on one machine so far, but will try on my laptop at home as well to verify it's 100% reproducible in in F10->F11B upgrades.

Steps to Reproduce:
1. Upgrade from F10
2. Create new user, or login as existing user
3. Note splash screen is shown, when None is set (and expected)
  
Actual results:
Headache-inducing white splash screen is shown.

Expected results:
No splash screen, just nice gentle transition to desktop

Additional info:
None
Comment 1 Kevin Fenzi 2009-04-01 23:16:08 EDT
So, this is a solid white screen? No anything like any of the other splash screens?

Your xfce4-session is that 4.5.99.1-1.fc10 one? Even after the upgrade to f11?
Comment 2 Kevin Fenzi 2009-04-06 23:10:24 EDT
Did upgrading to 4.6.x fix things?
Comment 3 Kevin Fenzi 2009-04-30 18:23:41 EDT
Any news here? Did 4.6.x from f11 fix things?
Comment 4 Walter Francis 2009-05-02 17:13:33 EDT
I don't know if I did something silly to start with or what, but I can no longer reproduce this.

Reproduction setup:

Installed F10 (minimal install, XFCE) with netinst.iso.  Created two users, one which I customized the XFCE environment (panels, stuff in the panels etc) and one which I just logged into XFCE.

Ran the F11 Preview DVD, upgraded the system.  Booted up the new system.  (had to run fixfiles, selinux was hosing HAL....)

Logged in with both users.  Both had their environment preserved.  XFCE looks and works fine in both.  No splash screen, panels are configured fine, icons look okay etc.

Ran yum groupupdate xfce-desktop

Now both users panels are missing icons and are a bit funky looking..  Arrangements are about right still I think, but looks like some of the icons names changed perhaps.

If this is too much bug creep let me know, I can log a separate bug.  The original splash screen I didn't see the problem with.  But not sure that this icon deal is expected or acceptable?  I'm attaching a screenshot.
Comment 5 Walter Francis 2009-05-02 17:14:24 EDT
Created attachment 342199 [details]
Screenshot of default XFCE configuration in F10, upgraded to F11's XFCE
Comment 6 Kevin Fenzi 2009-05-03 21:44:54 EDT
If you go to Prefs -> Appearence -> Icons 
what is selected? If you select "Rodent" do the icons start working?
Comment 7 Walter Francis 2009-05-03 21:52:15 EDT
Icon Theme is "Fedora", and changing through all of the themes does not make the icons appear on either user with a pre-existing XFCE configuration.  A new user I created post-XFCE 4.6 does have the proper icons.
Comment 8 Kevin Fenzi 2009-05-10 00:40:12 EDT
This seems to be: http://bugzilla.xfce.org/show_bug.cgi?id=5067

which is fixed in 4.6.1. 

I just did a quick test here with a f10 xfce user going to rawhide, and it picked up all the icons ok. 

If you can confirm this, we can go ahead and close this bug?
Comment 9 Walter Francis 2009-05-10 01:49:06 EDT
Yep, looks good with update from F10 with a few test users similar to the previous entries and updating to F11, doing yum groupupdate xfce-desktop and logging in as the two existing users.  Icons were preserved, everything looks okay!
Comment 10 Kevin Fenzi 2009-05-10 01:54:33 EDT
cool. Closing this one now then... feel free to reopen or file a new one if you spot anything further.

Note You need to log in before you can comment on or make changes to this bug.