This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 493485 - tg3 - DMA-API: device driver tries to sync DMA memory it has not allocated
tg3 - DMA-API: device driver tries to sync DMA memory it has not allocated
Status: CLOSED DUPLICATE of bug 484624
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 18:10 EDT by Mike Gahagan
Modified: 2009-04-28 11:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 11:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2009-04-01 18:10:40 EDT
Description of problem:

It appears we hit this warning while attempting to get an IP from the dhcp server.

<29>Apr  1 18:38:10 NetworkManager: <info>  dhclient started with pid 1621

<29>Apr  1 18:38:10 NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.

<29>Apr  1 18:38:10 NetworkManager: <info>  DHCP: device eth0 state changed (null) -> preinit

<30>Apr  1 18:38:10 dhclient: Listening on LPF/eth0/00:19:bb:49:7d:5a
<30>Apr  1 18:38:10 dhclient: Sending on   LPF/eth0/00:19:bb:49:7d:5a
<30>Apr  1 18:38:10 dhclient: Sending on   Socket/fallback
<4>------------[ cut here ]------------
<4>WARNING: at lib/dma-debug.c:539 check_sync+0x103/0x352() (Not tainted)
<4>Hardware name: HP xw6400 Workstation
<4>tg3 0000:1f:00.0: DMA-API: device driver tries to sync DMA memory it has not allocated [device address=0x0000003c00000000] [size=0 bytes]
<4>Modules linked in: nouveau drm i2c_core tg3 iscsi_ibft iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ext2 ext4 jbd2 crc16 squashfs pcspkr edd floppy nfs lockd nfs_acl auth_rpcgss sunrpc vfat fat cramfs
<4>Pid: 0, comm: swapper Not tainted 2.6.29-21.fc11.i586 #1
<4>Call Trace:
<4> [<c0430aa3>] warn_slowpath+0x7c/0xa7
<4> [<c044e676>] ? find_usage_forwards+0x71/0x90
<4> [<c044f9f1>] ? check_usage_forwards+0x1d/0x3f
<4> [<c044e339>] ? graph_unlock+0x64/0x70
<4> [<c044fa70>] ? mark_lock+0x1e/0x30b
<4> [<c044e339>] ? graph_unlock+0x64/0x70
<4> [<c0450fe8>] ? __lock_acquire+0xa30/0xad1
<4> [<c0549d02>] ? get_hash_bucket+0x26/0x2f
<4> [<c0549d02>] ? get_hash_bucket+0x26/0x2f
<4> [<c0549e0e>] check_sync+0x103/0x352
<4> [<c04a2e11>] ? check_valid_pointer+0x21/0x4f
<4> [<c044fa70>] ? mark_lock+0x1e/0x30b
<4> [<c054a1d1>] debug_dma_sync_single_for_cpu+0x23/0x2d
<4> [<f7f3b13c>] pci_dma_sync_single_for_cpu.clone.1+0x3a/0x48 [tg3]
<4> [<f7f3b64b>] tg3_poll+0x501/0x7a1 [tg3]
<4> [<c066a7ae>] net_rx_action+0x9d/0x1c0
<4> [<c043573a>] __do_softirq+0x99/0x152
<4> [<c0435845>] do_softirq+0x52/0x7e
<4> [<c04359b0>] irq_exit+0x49/0x77
<4> [<c0405a36>] do_IRQ+0x97/0xad
<4> [<c040452c>] common_interrupt+0x2c/0x40
<4> [<c044007b>] ? alloc_pid+0xf8/0x2d2
<4> [<c0409415>] ? mwait_idle+0x73/0xa3
<4> [<c0402ff7>] cpu_idle+0x72/0x93
<4> [<c06ea9a3>] start_secondary+0x198/0x19d
<4>---[ end trace fdd02df95cae90cf ]---
<30>Apr  1 18:38:12 dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3


Version-Release number of selected component (if applicable):
rawhide-20090401

How reproducible:
only tried once

Steps to Reproduce:
1.kickstart install over nfs
2.
3.
  
Actual results:


Expected results:
no kernel warnings

Additional info:
Comment 2 Jerry Amundson 2009-04-28 11:43:12 EDT

*** This bug has been marked as a duplicate of bug 484624 ***

Note You need to log in before you can comment on or make changes to this bug.