Bug 493494 - no video display on bootup
no video display on bootup
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 19:44 EDT by jeremy boyd
Modified: 2009-04-09 20:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 20:11:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeremy boyd 2009-04-01 19:44:32 EDT
Description of problem: i'm using an hp pavilion dv7 model 1124ca laptop. this has an nvidia geforce 9600m gt graphics card. i installed fedora alpha several months ago and the computer booted up fine. i didn't install any proprietary nvidia drivers but an using the NV driver. after doing an update that included a new kernel i rebooted the machine and after the progress bar section of bootup the screen went black and after several minutes i rebooted in the original f11 alpha kernel with no problems. after every kernel update i get the same problem. no display after the progress bar completes. i have continued to update all packages but i still use the original kernel. this problem also happened with the f11 beta live cd. after several minutes of the live cd booting up the screen goes blank. it also happens with the f11 beta dvd installer. after the screen where you can test the install media the screen goes blank. i think the last thing i saw when booting the installer was that anaconda was loading.


Version-Release number of selected component (if applicable):all kernels since original f11 alpha kernel. not sure what version it was.


How reproducible: always


Steps to Reproduce:
1. boot machine
2. wait til progress bar finishes
3.
  
Actual results: screen goes blank


Expected results: login screen should appear


Additional info:
Comment 1 jeremy boyd 2009-04-04 10:11:01 EDT
i was able to get the computer booted up by using the vesa driver. once i was logged into my account i installed the proprietary nvidia drivers and rebooted. after this the kernel worked so i assume its a nouveau thing.
Comment 2 Matěj Cepl 2009-04-06 19:15:01 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) while running nouveau driver to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Ben Skeggs 2009-04-09 02:02:16 EDT
I'll re-mark this as a nouveau bug, not an nv bug.  Are you certain it was the kernel update that caused the issue?  I can think of a bug that would've been in xorg-x11-drv-nouveau around the time you reported the bug which may have caused this, that's now been fixed.

So, an update may help.  If not, the logs mentioned by Matej will be a huge help in resolving this.
Comment 4 jeremy boyd 2009-04-09 17:59:45 EDT
unfortunately i installed ubuntu on my laptop so i don't have a copy of that log file anymore. i couldn't say if the bug went away because after i installed the proprietary nvidia drivers my display worked. sorry i can't get you any more info.

jeremy boyd
Comment 5 Ben Skeggs 2009-04-09 20:11:31 EDT
Ok, thank you!

Note You need to log in before you can comment on or make changes to this bug.