Bug 4935 - Using quotas on some disks causes uninterruptable sleep and crashes.
Using quotas on some disks causes uninterruptable sleep and crashes.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
5.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-06 00:57 EDT by jpavel
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 10:36:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jpavel 1999-09-06 00:57:16 EDT
I had quotas running on a 600MB partition for a long time,
with no problems. I installed a 17.2GB disk and partitioned
it into 4.3GB chunks, and attempted to set up user quotas on
the new partitions. When I did so, I encountered these
problems:

Running  repquota to display information on the new
partitions causes the repquota process to go into
uninterruptable sleep, as reported by ps, and cannot be
killed. From that point on, any operation which attempts to
write to that new partition hangs into an uninterruptable
sleep. When the shutdown procedure attempts to unmount the
afflicted partition, it too hangs, and I have to reboot the
machine manually, via the reset switch.

The hardware is a K6-333, 96MB of RAM, 3.2GB IDE drive
(master on primary IDE) and a 17.2GB IDE drive (slave on
secondary IDE), CD-ROM (master on secondary IDE).

I am currently running without quotas enabled, and
everything else works fine. Posts on comp.os.linux.misc
brought me into contact with a person from Ohio State
University who encountered the same problem.

Thanks,
Jesse
Comment 1 michael.guntzburger 1999-10-06 08:30:59 EDT
I have the same problem on HP netserver SMP. linux 6.0, kernel version
2.2.5-15smp

extract of dmesg :
(scsi0) <Adaptec AIC-7895 Ultra SCSI host adapter> found at PCI 5/0
(scsi0) Wide Channel A, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 374 instructions downloaded
(scsi1) <Adaptec AIC-7895 Ultra SCSI host adapter> found at PCI 5/1
(scsi1) Wide Channel B, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 374 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI)
5.1.15/3.2.4
       <Adaptec AIC-7895 Ultra SCSI host adapter>
scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI)
5.1.15/3.2.4
       <Adaptec AIC-7895 Ultra SCSI host adapter>
scsi : 2 hosts.
(scsi0:0:0:0) Synchronous at 40.0 Mbyte/sec, offset 8.
  Vendor: HP        Model: 9.10GB A 68-B001  Rev: B001
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:0:1:0) Synchronous at 40.0 Mbyte/sec, offset 8.
  Vendor: HP        Model: 9.10GB A 68-B001  Rev: B001
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB]
[8.7 GB]
 sda: sda1 sda2 < sda5 sda6 >
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 17773524 [8678 MB]
[8.7 GB]
 sdb: sdb1 sdb2

And, when I change a password, the process is hung, or when I run syn
c command.
Comment 2 giuliano 2000-06-23 07:32:39 EDT
Me too.
For my redhat 6.0 the problem is that when i enable quota on a fs, each
operation involving write to a disk will endlessy sleep.
I must reset the computer.
Comment 3 Preston Brown 2001-03-19 10:03:29 EST
I don't know where this bug was hiding, it just got assigned to me.

I cannot duplicate any of these behaviours in Red Hat Linux 6.2 or 7.0, our 
currently supported versions.

Note You need to log in before you can comment on or make changes to this bug.