Bug 493504 - Nouveau driver supports max resolution of 1680x1680
Nouveau driver supports max resolution of 1680x1680
Status: CLOSED DUPLICATE of bug 487356
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 21:00 EDT by Casey Jones
Modified: 2009-04-01 21:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 21:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casey Jones 2009-04-01 21:00:58 EDT
Description of problem:
I have two monitors, one is 1680x1050, the other is 1280x1024.  When I boot up Fedora, it automatically sets the monitors to mirror each other, and they are both set as 1280x1024.  This also affects Plymouth.

When I try setting the native resolution on my 22" screen using the Display dialog in Preferences, I get this error: Could not apply selected configuration: required virtual size does not fit available size: requested=(2960, 1050), minimum=(320, 200), maximum=(1680, 1680)

Version-Release number of selected component (if applicable):
Fedora 11 Rawhide (April 1)

How reproducible:
Always

Steps to Reproduce:
1. Use two displays with a combined resolution greater than 1680x1680
2. Set resolution to greater than 1680x1680.
  
Actual results:
Error pops up, and I'm forced to turn off one display.

Expected results:
Native resolution on both displays.

Additional info:
Like I said, this also affects plymouth.  I get plymouth loading on each screen, and on the 22" screen, it's set to 1280x1024, so I get a big black border around it.
Comment 1 Ben Skeggs 2009-04-01 21:12:43 EDT
> Steps to Reproduce:
> 1. Use two displays with a combined resolution greater than 1680x1680
> 2. Set resolution to greater than 1680x1680.
> 
> Actual results:
> Error pops up, and I'm forced to turn off one display.
> 
> Expected results:
> Native resolution on both displays.
Unfortunately, for the moment you're going to have to create an xorg.conf and set a Virtual like that's large enough to cover both your displays.  There's more info on this in the bug I'm going to mark this as a duplicate of.
 
> Additional info:
> Like I said, this also affects plymouth.  I get plymouth loading on each
> screen, and on the 22" screen, it's set to 1280x1024, so I get a big black
> border around it.
This is the "correct" (well, expected) behaviour currently.

Thanks!
Ben.

*** This bug has been marked as a duplicate of bug 487356 ***

Note You need to log in before you can comment on or make changes to this bug.