Bug 493507 - [radeon test day] vt switch failed, kms [mobility x1600]
[radeon test day] vt switch failed, kms [mobility x1600]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 21:23 EDT by Bill McGonigle
Modified: 2009-05-23 16:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 21:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
As requested, my Xorg.log. (31.92 KB, text/plain)
2009-04-06 15:53 EDT, Stan Trzmiel
no flags Details
My xorg.conf (1.58 KB, text/plain)
2009-04-06 15:58 EDT, Stan Trzmiel
no flags Details
Xorg.0.log (75.35 KB, text/plain)
2009-04-08 23:15 EDT, Bill McGonigle
no flags Details
Xorg.1.log (18.30 KB, text/plain)
2009-04-08 23:16 EDT, Bill McGonigle
no flags Details
Xorg.2.log (18.30 KB, text/plain)
2009-04-08 23:16 EDT, Bill McGonigle
no flags Details
Xorg.3.log (18.30 KB, text/plain)
2009-04-08 23:17 EDT, Bill McGonigle
no flags Details
Xorg.4.log (18.48 KB, text/plain)
2009-04-08 23:17 EDT, Bill McGonigle
no flags Details
Xorg.5.log (71.57 KB, text/plain)
2009-04-08 23:17 EDT, Bill McGonigle
no flags Details
Xorg.6.log (55.97 KB, text/plain)
2009-04-08 23:21 EDT, Bill McGonigle
no flags Details

  None (edit)
Description Bill McGonigle 2009-04-01 21:23:21 EDT
Description of problem:

trying to switch from liveuser to console with ctrl-alt-f2 results in a graphical screen on both displays showing the original fedora logo screen, with a bunch of display garbage, but no vc.  

At that point, switching with ctrl-alt-f1 or just alt-f1 does nothing, but I can can back to a second user on f7, then fast-user-switch back to the first user.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.12.1-2.fc11.i586

How reproducible:

always

Steps to Reproduce:
1. try to switch to vc
2
3.
  
Actual results:

video garbage

Expected results:

vc

Additional info:

smolt:

http://www.smolts.org/client/show/pub_84fdcccc-d29d-4a50-8032-3855cfb8ff32
Comment 1 Stan Trzmiel 2009-04-04 18:05:26 EDT
Here VT switch with KMS enabled is broken too.
Attempt to use ctrl+alt+F(x) keys causes display go blank and monitor to turn off/on in infinite loop. IT happen both on my F10 and F11 install.

Related packages
kernel-2.6.29.1-46.fc11.i686.PAE
libdrm-2.4.5-3.fc11.i586
xorg-x11-drv-ati-6.12.1-4.fc11.i586
xorg-x11-server-common-1.6.0-16.fc11.i586

Hardware:
Radeon 9550 128 MB AGP
14" non-plug&play CRT (configured via modelines/prefferedmode in xorg.conf)

My smolt profile
http://www.smolts.org/show?uuid=pub_4310253d-c52d-4e95-98ae-9d8bd21e44ca
Comment 2 Matěj Cepl 2009-04-06 09:53:50 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Stan Trzmiel 2009-04-06 15:53:40 EDT
Created attachment 338386 [details]
As requested, my Xorg.log.
Comment 4 Stan Trzmiel 2009-04-06 15:58:30 EDT
Created attachment 338389 [details]
My xorg.conf

In fact xorg.conf doesn't matter. I also run test with config file renamed, so X server would run on default settings and effects were the same.
Comment 5 François Cami 2009-04-06 16:30:29 EDT
  Bill,

If it is at all possible, please attach your Xorg.*.log files
as well. Stan has a different card (AGP).

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Bill McGonigle 2009-04-08 23:15:29 EDT
Created attachment 338840 [details]
Xorg.0.log
Comment 7 Bill McGonigle 2009-04-08 23:16:09 EDT
Created attachment 338841 [details]
Xorg.1.log
Comment 8 Bill McGonigle 2009-04-08 23:16:50 EDT
Created attachment 338842 [details]
Xorg.2.log
Comment 9 Bill McGonigle 2009-04-08 23:17:11 EDT
Created attachment 338843 [details]
Xorg.3.log
Comment 10 Bill McGonigle 2009-04-08 23:17:31 EDT
Created attachment 338844 [details]
Xorg.4.log
Comment 11 Bill McGonigle 2009-04-08 23:17:50 EDT
Created attachment 338845 [details]
Xorg.5.log
Comment 12 Bill McGonigle 2009-04-08 23:21:05 EDT
Created attachment 338846 [details]
Xorg.6.log

Hrm, more X logs than I expected.

These were created with the testday CD with the -4.11 server applied over it (the latest that would work with the test day kernel).

  http://koji.fedoraproject.org/koji/buildinfo?buildID=96475

Today, I couldn't fast-user switch back and forth with the GNOME menu item, VT switching worked among f2-f7, but never back to f1.
Comment 13 Stan Trzmiel 2009-04-09 06:57:57 EDT
Latest update fixed Vt switch for me. I can jump ctrl+alt+F1-F6 all day long with no problems.
Switching users also works like charm :)

My packages are now:
kernel-2.6.29.1-54.fc11.i686.PAE
xorg-x11-drv-ati-6.12.1-9.fc11.i586
libdrm-2.4.6-3.fc11.i586

THANKS!
Comment 14 François Cami 2009-04-10 15:27:20 EDT
Bill, thank you for the logs.

kernel-2.6.29.1-54 fixed the VT switch. Closing, if this problem reappears, please feel free to reopen.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Bill McGonigle 2009-04-10 16:07:50 EDT
Thanks, François.  I'll be on the lookout for a -pre liveCD.
Comment 16 Stan Trzmiel 2009-04-12 12:07:40 EDT
Hi,
May I ask to reopen this one. Latest update of librdm package to lidrm-2.4.6-4.fc11.i586 broke VT switching once again. Also reduced glxgears performace occurs. IT lost about 23% from ~680fps down to ~530fps. I know glxgears is not good performance measure tool but atm is the only available now (other 3D apps still doesn't use hardware acceleration) and performance decrease is quite significant.
Comment 17 François Cami 2009-04-12 12:27:16 EDT
Reopening.
Could you downgrade libdrm to the previous version and check if it really worked better ? The builds are in koji :
http://koji.fedoraproject.org/koji/packageinfo?packageID=770

Thanks

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Stan Trzmiel 2009-04-12 12:46:15 EDT
I've allready done it to confirm if it's really new libdrm problem. With downgrade to libdrm-2.4.6-3.fc11 VT switch started to work again and glxgears runs as fast as before.
Comment 19 François Cami 2009-04-12 12:50:55 EDT
Ok, thank you Stan.
Comment 20 Stan Trzmiel 2009-04-16 15:47:01 EDT
Latest updates (kernel-PAE-2.6.29.1-85.fc11.i686, libdrm-2.4.6-5.fc11.i586) didn't change much. The performance is back, but VT-switch still broken.
Should I report it as separate bug in librm component?

BTW. When I boot with libdrm-2.4.6-3.fc11.i586 before Plymouth kicks in I can see message: "Not responding". I couldn't find anything interesting in dmesg and messages but still have'em stored just in case.
Comment 21 Stan Trzmiel 2009-04-16 15:48:49 EDT
Edit in addendum note should be libdrm-2.4.6-5.fc11.i586, not -3. With libdrm-2.4.6-3.fc11.i586 there's no messages before Plymouth.
Comment 22 Bill McGonigle 2009-05-06 18:40:32 EDT
Tested out the F11-pre LiveCD, no vt switching there either (Mobility x1600).
Comment 23 Stan Trzmiel 2009-05-10 18:59:18 EDT
Update kernel from 2.6.29.3-126 to 2.6.29.3-130 fixed VT for me.
Comment 24 Adam Pribyl 2009-05-14 02:30:18 EDT
I have the latest kernel 2.6.29.2-126.fc11.i686.PAE from F11 repo on ATI Technologies Inc RV280 [Radeon 9200] and with KMS enabled, I can not switch to any vt console. Without KMS this is working OK.
This bug also prevents getting vt during system installation.
Comment 25 Stan Trzmiel 2009-05-14 06:05:24 EDT
Try 2.6.29.3-130 or later, VT switch didn't work for me in -126 too.
Comment 26 François Cami 2009-05-14 06:06:12 EDT
Bill, Adam, 

Could you update to kernel-2.6.29.2-129.fc11 or later and report ?
http://koji.fedoraproject.org/koji/packageinfo?packageID=8
Could you also check that you are running mesa-libGL-7.5-0.14.fc11 ?

Thank you

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Adam Pribyl 2009-05-14 10:48:08 EDT
Ok with 2.6.29.2-129 vt is accesible. For me just significant is, wherether this will be in F11 install, but I doubt because this is not even in f11 updates.
Comment 28 François Cami 2009-05-14 11:01:01 EDT
A kernel containing the fixes should be in the 0-day updates.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Bill McGonigle 2009-05-14 13:34:03 EDT
I can't seem to find an updated LiveCD beyond PR1 (I don't have rawhide on this machine) - if anybody happens to know of a nightly build please let me know.

If not I'll dig up a USB drive big enough to hold a rawhide install.  The live CD's are nicely built for updating RPM's after boot, but not for kernel. :)
Comment 30 Bill McGonigle 2009-05-21 02:25:23 EDT
I don't think I'm getting vt switching on current stuff.  It's still ctrl-alt-fkey, right?

kernel: 2.6.29.3-140.fc11.i586
xorg-x11-drv-radeonhd-1.2.5-2.8.20090411git.fc11.i586

If I try ctrl-alt-f2,3,4,5,6,7 I just don't see any response.  I tried a second keyboard just in case.

Let me know what else I can do.
Comment 31 Bill McGonigle 2009-05-21 02:30:35 EDT
Oh, this is from X.  If I'm at runlevel 3 I can vt switch.
Comment 32 Bill McGonigle 2009-05-21 02:48:30 EDT
I saw X was pegging a CPU so I strace'ed it, which unexpectedly locked the machine, so I rebooted and after that vt switching seems to be working now, among X sessions and text consoles.
Comment 33 Bill McGonigle 2009-05-22 21:08:44 EDT
Also got a kernel update to 2.6.29.3-155.fc11.i586, things are still working well.
Comment 34 Matěj Cepl 2009-05-23 16:02:48 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.