Bug 493509 - [PATCH] ibus-hangul missing right Ctrl for Hanja button
[PATCH] ibus-hangul missing right Ctrl for Hanja button
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus-hangul (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker 481098
  Show dependency treegraph
 
Reported: 2009-04-01 22:45 EDT by Warren Togami
Modified: 2009-04-13 14:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 14:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-04-01 22:45:38 EDT
Windows XP and Windows Vista with US keyboard layout.

* right-Alt acts as Hangul/English button.  It does not dismiss the language bar.  It only switches between 한 and En.
* right-CTRL acts as Hanja button.

We need this by default because it is very common for Koreans with US keyboards to expect this interface.
Comment 1 Warren Togami 2009-04-06 16:48:54 EDT
diff -urN ibus-hangul-1.1.0.20090328.orig/src/engine.c ibus-hangul-1.1.0.20090328/src/engine.c
--- ibus-hangul-1.1.0.20090328.orig/src/engine.c	2009-03-26 01:50:18.000000000 -0400
+++ ibus-hangul-1.1.0.20090328/src/engine.c	2009-04-06 16:20:44.935321507 -0400
@@ -450,7 +450,7 @@
     if (keyval == IBUS_Shift_L || keyval == IBUS_Shift_R)
         return FALSE;
 
-    if (keyval == IBUS_F9 || keyval == IBUS_Hangul_Hanja) {
+    if (keyval == IBUS_F9 || keyval == IBUS_Hangul_Hanja || keyval == IBUS_Control_R) {
 	ibus_hangul_engine_toggle_lookup_table (hangul);
 	return TRUE;
     }

This makes it work for the non-Korean keyboard Hanja conversion button.  Filing the right Alt Han/En button as a separate bug since it requires more work.

Note You need to log in before you can comment on or make changes to this bug.