Bug 493516 - [radeon test day] Suspend fails with Radeon HD 3850 / GA-965P-S3 rev 1.0 / WD Raptor 150GB
[radeon test day] Suspend fails with Radeon HD 3850 / GA-965P-S3 rev 1.0 / WD...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 23:48 EDT by Stewart Adam
Modified: 2015-03-04 20:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-19 14:20:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2009-04-01 23:48:28 EDT
Description of problem:
When attempting to suspend, the hard disk powers down but that's all - the screen remains active. The cursor & keyboard inputs are frozen, so a power cycle is required to get the machine in a usable state again.

Version-Release number of selected component (if applicable):
Test day 2009-04-01 Live CD:
* pm-utils-1.2.4-2.fc11.x86_64
* xorg-x11-drv-ati-6.12.0-2.fc11.x86_64
* kernel-2.6.29-21.fc11.x86_64

How reproducible:
Only tested once

Steps to Reproduce:
1. Boot with radeon.modeset=1 (Using R600 hardware)
2. Remove the /usr/lib64/pm-utils/sleep.d/90chvt file
3. Suspend the machine
  
Actual results:
Hard disk powers down, machine hangs

Expected results:
Machine suspends correctly (screen enters powersave mode, system enters reduced power state)

Additional info:
Smolt profile: http://smolt.fedoraproject.org/show?uuid=pub_f2464a1c-0f51-4652-8830-fa985b02ac30
Comment 1 François Cami 2009-04-10 17:06:43 EDT
  Stewart,

Could you add your dmesg as uncompressed text/plain attachment to this bug ?
What happens without radeon.modeset=1 ?

Thank you

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 François Cami 2009-04-10 17:07:27 EDT
Please add /var/log/Xorg.0.log as uncompressed text/plain attachment as well.
Comment 3 Stewart Adam 2009-04-19 14:20:25 EDT
I was testing this with Fedora 11 Snapshot 1 and noticed that this also occurred when modesetting was disabled, or even if X was never started... I updated my USB key and to these package versions:
* pm-utils-1.2.5-1.fc11.x86_64
* kernel-2.6.29.1-54.fc11.x86_64

Without radeon.modeset=1 suspend works perfectly, unfortunately I can't test with radeon.modeset=1 as Xorg crashes (bug 496504). I think this can be closed since I could also reproduce the problem without modesetting, and that's been fixed now.

Note You need to log in before you can comment on or make changes to this bug.