Bug 493518 - Fedora 9 does not have virtio PXE ROM - PXE booting Fedora 10 guests under virt-manager fails
Fedora 9 does not have virtio PXE ROM - PXE booting Fedora 10 guests under vi...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 00:06 EDT by Joseph Shraibman
Modified: 2009-07-14 11:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (36.57 KB, image/png)
2009-04-02 00:08 EDT, Joseph Shraibman
no flags Details
virt-manager.log (481.13 KB, text/plain)
2009-04-03 11:25 EDT, Joseph Shraibman
no flags Details
screenshot (33.59 KB, image/png)
2009-04-03 11:27 EDT, Joseph Shraibman
no flags Details
virt-manager.log (39.05 KB, text/plain)
2009-04-06 10:56 EDT, Joseph Shraibman
no flags Details

  None (edit)
Description Joseph Shraibman 2009-04-02 00:06:19 EDT
Description of problem:
If the  "PXE Install" option is selected, when the finish button is clicked a popup appears that says:
Unable to complete install: 'internal error QEMU quit during console startup
No valid PXE rom found for network device
'

virt-manager should not try to create a virtual machine with a virtual ethernet device that doesn't have a pxe boot rom, and it should have a better error message.  I don't know what file is missing because the error message doesn't say.

Version-Release number of selected component (if applicable):
I tried this with 0.7.0 and the bug is still there

How reproducible:
Always


Additional info:
See also bug 489823, but I think this is more than just a documentation issue because a non-working option is offered to the user.
Comment 1 Joseph Shraibman 2009-04-02 00:08:47 EDT
Created attachment 337716 [details]
screenshot
Comment 2 Mark McLoughlin 2009-04-03 07:01:20 EDT
What versions of virt-manager, python-virtinst, libvirt, qemu and kvm are you using?

Is this a KVM guest or a QEMU guest?

Please attach ~/.virt-manager/virt-manager.log and /var/log/libvirt/qemu/$(guest).log
Comment 3 Joseph Shraibman 2009-04-03 11:25:06 EDT
The versions of everything are whatever the current fc9 packages are.

KVM.  That was the default and I didn't think changing it would make any difference.  I just tried and the virtual machine does indeed start up when I change the hypervisor to kqemu.  That was with virt-manager 0.6.0.  With 0.7.0 that I downloaded from the virt-manager website the virtual machine starts but an error popup appears.

There is no /var/log/libvirt/qemu/ directory
Comment 4 Joseph Shraibman 2009-04-03 11:25:59 EDT
Created attachment 338063 [details]
virt-manager.log
Comment 5 Joseph Shraibman 2009-04-03 11:27:56 EDT
Created attachment 338066 [details]
screenshot

This is a screenshot of the error virt-manager 0.7.0 gave me when starting up a kqemu virt machine booting via PSXE
Comment 6 Mark McLoughlin 2009-04-06 05:14:23 EDT
Listing the exact versions of qemu, libvirt, python-virtinst and virt-manager would make things easier. Please do in future, thanks

/var/log/libvirt/qemu/ should exist - maybe only newer versions of libvirt create it.

The virt-manager 0.7.0 error is fixed in rawhide with:

  http://cvs.fedoraproject.org/viewvc/rpms/virt-manager/devel/virt-manager-0.7.0-vm-migrate-list.patch?view=markup

You'd be better off reverting to the official F9 version.


The "No valid PXE rom found for network device" error is because /usr/share/qemu/pxe-virtio.bin doesn't exist on F9. It was introduced in Fedora 11.

As a workaround try using a different distro version - when installing a Fedora 10 guest, virt-manager will make the guest use virtio which isn't going to work. So, try e.g. saying the guest is Fedora 9.

Please let us know if that works
Comment 7 Joseph Shraibman 2009-04-06 09:10:30 EDT
Trying a fedora 9 guest didn't work either :(
Comment 8 Mark McLoughlin 2009-04-06 10:38:22 EDT
(In reply to comment #7)
> Trying a fedora 9 guest didn't work either :(  

Try Fedora 8?

Please attach the virt-manager.log excerpt from this failure - e.g. I would not expect to see:

    <model type='virtio'/>

in the domain's XML.
Comment 9 Joseph Shraibman 2009-04-06 10:56:03 EDT
Created attachment 338341 [details]
virt-manager.log
Comment 10 Joseph Shraibman 2009-04-06 10:59:35 EDT
Trying Fedora 8 (after I uploaded the log file) did indeed start a vm trying to PXE boot.  I didn't proceed to actually boot something, but I should be able to boot Fedora 9/10/11 after selecting Fedora 8, right?
Comment 11 Mark McLoughlin 2009-04-06 13:26:53 EDT
Great, thanks for confirming.

Okay, summary is:

  F9 does not have a PXE ROM for virtio; virt-manager/virtinst should never
  try and PXE boot a guest using a virtio NIC, even if the guest is F9/10/11
Comment 12 Daniel Berrange 2009-05-06 06:58:20 EDT
What RPM of virt-manager do you have installed in Fedora 9 host ?

AFAIK, we have not released 0.7.0 for a Fedora 9 update.
Comment 13 Cole Robinson 2009-05-06 11:06:13 EDT
kvm in f9 doesn't allow PXE booting with a virtio interface. virtinst 0.400.0 is hardcoded to work around it, but that was reverted in 0.400.1 and later, since F10 kvm at least no longer complained.

My guess is the reporter pulled virtinst 0.400.3 out of updates-testing which doesn't have the workaround (which I'll fix).
Comment 14 Joseph Shraibman 2009-05-06 12:15:16 EDT
I first filed this bug after trying with the released virt-manager and with 0.7.0 that I built from source.
Comment 15 Bug Zapper 2009-06-09 23:39:15 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2009-07-14 11:01:47 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.