Bug 493566 - geany-devel must requires pkgconfig
geany-devel must requires pkgconfig
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: geany (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 05:42 EDT by Pierre-YvesChibon
Modified: 2009-04-09 12:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.16-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 12:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2009-04-02 05:42:02 EDT
Description of problem:
According to the guidelines [1] geany-devel must requires pkgconfig

And I actully need it to build the geanyvc plugin :)

[1] http://fedoraproject.org/wiki/Packaging/Guidelines#PkgconfigFiles

Thanks
Comment 1 Parag AN(पराग) 2009-04-02 05:54:17 EDT
Ok. So when geany got reviewed there was no .pc files provided by geany package in 0.10 version.
This change should have brought in 0.12-1 release.
Comment 2 Jonathan Underwood 2009-04-02 07:06:13 EDT
Could catch. Have kicked off builds fixing this. Nice to see someone packaging plugins :)
Comment 3 Pierre-YvesChibon 2009-04-02 07:24:17 EDT
Seing the Changelog of the spec I start to understand why the owner did not reply me when I ping him some weeks ago ^^


Jonathan, could you please let me know when there is an update in Geany since the plugin are version based/dependant ?

Thanks for the quick reaction thought :)
Comment 4 Fedora Update System 2009-04-02 07:34:38 EDT
geany-0.16-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/geany-0.16-2.fc10
Comment 5 Jonathan Underwood 2009-04-02 07:42:15 EDT
(In reply to comment #3)
> Seing the Changelog of the spec I start to understand why the owner did not
> reply me when I ping him some weeks ago ^^
> 

Yes, Josef told me sometime ago he wasn't particularly interested in the package.

> 
> Jonathan, could you please let me know when there is an update in Geany since
> the plugin are version based/dependant ?

Sure. Actually it would make sense for you to be a co-maintainer of geany - that way you'll get emailed all package updates, and can make changes to the main geany package too, if you need to. If you'd like to go this route, I suggest you apply via the pkgdb - I think Josef would need to authorize it tho at present.

> 
> Thanks for the quick reaction thought :)  

no probs.
Comment 6 Pierre-YvesChibon 2009-04-02 08:12:21 EDT
(In reply to comment #5)
> > 
> > Jonathan, could you please let me know when there is an update in Geany since
> > the plugin are version based/dependant ?
> 
> Sure. Actually it would make sense for you to be a co-maintainer of geany -
> that way you'll get emailed all package updates, and can make changes to the
> main geany package too, if you need to. If you'd like to go this route, I
> suggest you apply via the pkgdb - I think Josef would need to authorize it tho
> at present.

Thanks for the invitation, I will do that.
Comment 7 Josef Bacik 2009-04-02 08:53:42 EDT
You are approved, and Johnathon I've given you approve acl permissions, not entirely sure why i hadn't done that to begin with.  yell if you need anything else.
Comment 8 Jonathan Underwood 2009-04-02 13:02:55 EDT
Thanks Josef.
Comment 9 Fedora Update System 2009-04-02 13:19:23 EDT
geany-0.16-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geany'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3266
Comment 10 Fedora Update System 2009-04-09 12:12:04 EDT
geany-0.16-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.