Bug 493622 - ss segfaults when ipv6 is disabled
ss segfaults when ipv6 is disabled
Status: CLOSED DUPLICATE of bug 493578
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iproute (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
Depends On:
  Show dependency treegraph
Reported: 2009-04-02 08:43 EDT by Ralph Angenendt
Modified: 2009-04-07 05:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-07 05:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3475 None None None Never

  None (edit)
Description Ralph Angenendt 2009-04-02 08:43:25 EDT
Description of problem:

When using the ss binary from the iproute package on a machine with ipv6 disabled, ss segfaults.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

[root@localhost ~]# ss
State      Recv-Q Send-Q      Local Address:Port          Peer Address:Port   
Segmentation fault
[root@localhost ~]# strace ss
execve("/usr/sbin/ss", ["ss"], [/* 17 vars */]) = 0
brk(0)                                  = 0x856b000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3

close(4)                                = 0
open("/proc/net/tcp6", O_RDONLY)        = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

[root@localhost ~]# rm /etc/modprobe.d/disable-ipv6 && modprobe ipv6
[root@localhost ~]# ss
State      Recv-Q Send-Q      Local Address:Port          Peer Address:Port   
[root@localhost ~]# exit

Actual results:

ss segfaults

Expected results:

ss does not segfault
Comment 1 Marcela Mašláňová 2009-04-07 05:27:26 EDT

*** This bug has been marked as a duplicate of bug 493578 ***

Note You need to log in before you can comment on or make changes to this bug.