Bug 493640 - ipod not detected
ipod not detected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On: F11Blocker/F11FinalBlocker
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 09:30 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 18:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
-d output (99.31 KB, text/plain)
2009-04-03 13:48 EDT, Dave Jones
no flags Details
lshal output (160.07 KB, text/plain)
2009-04-03 13:50 EDT, Dave Jones
no flags Details
lshal output with vfat formatted ipod (147.50 KB, text/plain)
2009-04-04 15:16 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2009-04-02 09:30:53 EDT
rhythmbox-0.11.6-20.r6096.fc10.x86_64

when I start up rb with my new ipod classic plugged in, it asks me to initialise it. When I click the button, rb crashes with this message..

(rhythmbox:3303): Gtk-CRITICAL **: gtk_tree_store_get_value: assertion `VALID_ITER (iter, tree_store)' failed

(rhythmbox:3303): GLib-GObject-WARNING **: gtype.c:3940: type id `0' is invalid

(rhythmbox:3303): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
Comment 1 Dave Jones 2009-04-02 15:53:57 EDT
Updated to rawhide.  rhythmbox-0.12.0-3.fc11.x86_64

No longer crashes, but now when I plug in the ipod, nautilus opens up a file browser for it, but rb never even notices it got connected.
Comment 2 Bastien Nocera 2009-04-03 11:30:27 EDT
Is the device still empty/new at that point? Could you please attach the output of "rhythmbox -d" (loads of output) and lshal to this bug?
Comment 3 Dave Jones 2009-04-03 13:48:24 EDT
Created attachment 338092 [details]
-d output
Comment 4 Dave Jones 2009-04-03 13:50:04 EDT
Created attachment 338094 [details]
lshal output
Comment 5 Dave Jones 2009-04-03 13:50:50 EDT
yeah it's empty right now.
I also tried registering it on a mac to see if that would make any difference to it, it didn't.
Comment 6 Dave Jones 2009-04-03 14:43:24 EDT
this is kind of bizarre btw..

$ podsleuth --rescan
No iPods were found in the HAL device tree
Comment 7 Dave Jones 2009-04-03 20:47:29 EDT
also odd..

the 120GB sdb2 partition on the ipod shows up as..

  volume.is_mounted = false  (bool)

though it got automatically mounted when I plugged the ipod in...

/dev/sdb2              120G   196M   120G   1% /media/Dave Jones’s iPod
Comment 8 Bastien Nocera 2009-04-04 10:00:46 EDT
Does "gvfs-mount -li" show it as mounted? If not, then we have a HAL bug which needs fixing before Rhythmbox will recognise the device.
Comment 9 Dave Jones 2009-04-04 12:03:33 EDT
Drive(1): Apple iPod
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sdb'
  themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
  is_media_removable=1
  has_media=1
  is_media_check_automatic=1
  can_poll_for_media=1
  can_eject=0
  Volume(0): Dave Jones’s iPod
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     unix-device: '/dev/sdb2'
     label: 'Dave Jones’s iPod'
    themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
    can_mount=1
    can_eject=0
    Mount(0): Dave Jones’s iPod -> file:///media/Dave%20Jones%E2%80%99s%20iPod
      Type: GProxyMount (GProxyVolumeMonitorGdu)
      themed icons:  [drive-removable-media-usb]  [drive-removable-media]  [drive-removable]  [drive]
      can_unmount=1
      can_eject=0
      is_shadowed=0

I know ajax has the exact same ipod and his works, the difference between his and mine though is that his is formatted vfat, and mine is hfs+
Comment 10 Dave Jones 2009-04-04 14:31:45 EDT
I only just noticed this in dmesg ..

hfs: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.

This sounds like fail. I think maybe formatting it as vfat is the way forward.
Comment 11 Dave Jones 2009-04-04 15:14:28 EDT
Gar. I formatted it as vfat in itunes in Windows. Still doesn't show up at all in rhythmbox.

When I plug it in, it mounts as before, with nautilus popping up a file browser.

gvfs-mount shows it mounted as before.

I'll attach the new lshal output.
Comment 12 Dave Jones 2009-04-04 15:16:31 EDT
Created attachment 338177 [details]
lshal output with vfat formatted ipod
Comment 13 Dave Jones 2009-04-04 16:30:22 EDT
I don't know if this is relevant, but it might be a clue..
The icon nautilus puts on the desktop is a regular usb storage device icon, not an ipod.  So perhaps hal/devicekit isn't setting something it should ?
Comment 14 Dave Jones 2009-04-05 19:21:35 EDT
so when I click 'scan removable media' in rhythmbox, I get this spew ..

(19:09:58) [0xeb7770] [dump_volume_identifiers] rb-removable-media-manager.c:550: uuid = 260E-EB3C
(19:09:58) [0xeb7770] [dump_volume_identifiers] rb-removable-media-manager.c:550: unix-device = /dev/sdb1
(19:09:58) [0xeb7770] [dump_volume_identifiers] rb-removable-media-manager.c:550: label = IPOD
(19:09:58) [0xeb7770] [rb_removable_media_manager_add_volume] rb-removable-media-manager.c:588: Unhandled media
(19:09:58) [0xeb7770] [dump_volume_identifiers] rb-removable-media-manager.c:550: uuid = 260E-EB3C
(19:09:58) [0xeb7770] [dump_volume_identifiers] rb-removable-media-manager.c:550: unix-device = /dev/sdb1
(19:09:58) [0xeb7770] [dump_volume_identifiers] rb-removable-media-manager.c:550: label = IPOD
(19:09:58) [0xeb7770] [rb_generic_player_is_mount_player] rb-generic-player-source.c:876: device is not an audio player
(19:09:58) [0xeb7770] [rb_removable_media_manager_add_mount] rb-removable-media-manager.c:649: Unhandled media


after noticing that the hal code in rb-removable-media-manager.c was failing, I saw this comment below..

/* treat as audio player if ".is_audio_player" exists in the root of the volume  */

I created that file on the ipod, and restarted rb. The ipod then shows up in the tree on the left. and dragging songs to it copies them to it. Though it doesn't seem to update the index on the ipod, as it doesn't display them.
Is that workaround only for players that don't require a separate index?
Comment 15 Bastien Nocera 2009-04-07 09:15:07 EDT
Stupid question, but did you enable the iPod plugin in the preferences?

It's enabled by default, but you might have disabled it by mistake...

And remove the .is_audio_player file, it's supposed to contain data that should already be available through HAL.
Comment 16 Dave Jones 2009-04-07 09:23:32 EDT
heh, yeah it's enabled. You can see it in the debug log.
I even tried disabling, and re-enabling it.
And trying with/without the MTP pluging enabled.

I removed the .is_audio_player file just after the above comment, when I noticed it didn't do anything.
Comment 17 Bastien Nocera 2009-04-07 10:25:12 EDT
The problem is caused by the gdu volume monitor, which replaces the HAL one.

The HAL UDI of the device isn't exposed anymore, so Rhythmbox will fail to detect them. This affects iPod, PSP, Nokia tablets, and any mass storage players.
Comment 18 Matthias Clasen 2009-04-07 13:48:41 EDT
http://live.gnome.org/DeviceKit
Comment 19 Bastien Nocera 2009-04-09 14:31:49 EDT
Please test this updated package:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1287721
Comment 20 Dave Jones 2009-04-09 15:36:14 EDT
awesome! It detects, and lets me copy files to it in rb.
One small glitch - I need to go to a shell and run sync before I click eject, or the files don't end up on the ipod.
Comment 21 Bastien Nocera 2009-04-09 18:06:52 EDT
Cool. Let me close that bug already. Feel free to file a separate one for the missing files problems. This is probably a gvfs issue, given that we just ask gvfs to eject the device...
Comment 22 David Zeuthen 2009-04-09 22:31:23 EDT
(In reply to comment #20)
> awesome! It detects, and lets me copy files to it in rb.
> One small glitch - I need to go to a shell and run sync before I click eject,
> or the files don't end up on the ipod.  

In F10 we used to display a "device is busy" hubble that would switch to "device is safe to remove" when umount(8) returned (which is when all data has hit the disk). Unfortunately, with switching to a new storage detection subsystem in F11, we lost this feature. Maybe we can find some time to add it back.

Note You need to log in before you can comment on or make changes to this bug.